Craters, Drilled Holes, Underground not rendering

Evan Bolt shared this bug 2 years ago
Outdated

Hello,

My friends and I have been running a server on SurvivalServers and ran into an issue where things aren't rendering properly. Screenshots of various areas attached with inside and outside shots to show issues

We had a lake full of craters from meteor showers and none of the craters render, as well as any mines we've dug. All player-placed objects show up fine. I've looked for any duplicate vx2 files, as well as reinstalling the game, rebooting the server, etc. I've also attached log files, as well as the world config. Could this be a corrupt world file related to the issue the recent patch fixed? We tried running the world on our own hardware as well to ensure it wasn't a problem with the server. I also described the issue in a reddit post, which I've linked in case I missed anything here.

Replies (6)

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
3

We have the same problem. Here is our formal description:

We've now re-started the game on a dedicated (hosted) server several times. We keep having the same error eat our world within a few days of each restart.

Description:

1) Things appear to be just fine. We get meteors. We dig holes for ore. Life is great.


2) We log in, and at some point the ground is smooth as a baby's skin. No meteor craters visible. However, if you go into one of our digs (or a big meteor hole) you pass through the ground and are then "interior" to the world.

  • Passing through the world skin is impactful. You toss around a bit. You grunt like hitting a surface.
  • Once inside, the world is transparent. You can see everything underground.
  • It is not like the falling-through-the-planet glitch, in that you never fall. You just walk around inside the "actually" dug region (although with invisible walls) that is covered by illusionary replaced ground surface.
  • Once the voxel illusion glitch happens, we can even watch meteors hit the surface and leave no mark, but the crater is still there, still passable, and places us beneath the surface.

3) Mods:

We have the Modular Encounters Collection installed and Paint Guns.

  • In our first world we only had a portion of Modular Encounters.
  • In our next world we had the entire Modular Encounters.
  • In this world we stripped out the Ground Encounters because, we reasoned, it puts ships partially stuck into the planet then heals the ground around them. That seems suspicious. With it NOT installed, the error still occurred.

4) This is like a few other reported bugs, like the ghosting bug, but seems to be a different beast.


Troubleshooting:

  1. We've swapped hosts, wondering if it was a memory issue.
  2. We've stripped out Ground Encounters from Modular Encounters.
  3. We've upgraded the server to best of everything.

Proof:

In this last voxel illusion glitch I took a whole ton of pictures. I can post a bunch of half-in-the-ground or looking-through-the-world screenshots if there is any way that would help diagnose or better understand the problem. The person above has provided some pictures.

Further Troubleshooting:

  • Returned to 3am backup from prior day. World was back to fine. Holes were holes again.
  • Interesting and possibly diagnostic (?): We note that when in our underground Cryochambers (on initial startup) we can see through the ground (as if the glitch has occurred). On the moment of exiting the Cryo we either have the ground show up, or not.
  • This morning the glitch has re-occurred. So, between our logoff at midnight, and login at 7am, something ran and did a faulty voxel cleanup? What would run only when we are offline, and break the game for our next login? What routine does a voxel patch/check/management/repair/action automatically that might be causing this?
  • Maybe diagnostic: On one world, any time we left our base (where the big bore/drill operations happened) and then returned, the "STREAMING" button would appear as we got closer. Then at 400m (almost exactly) the server would crash. We sent several crash reports.

Further evidence:

We found several reddit posts that replicate our concern, more or less:

https://www.reddit.com/r/spaceengineers/comments/ess451/bug_transparent_ground_from_inside_the_caves_ive/

https://www.reddit.com/r/spaceengineers/comments/gayqb1/terrain_has_renewed_but_collision_didnt/

https://www.reddit.com/r/spaceengineers/comments/gfu17a/terrain_problem_anyway_to_fix_this_tried_with_the/?utm_source=share&utm_medium=ios_app&utm_name=iossmf


Early hypothesis:

We do a bunch of mining. We have lots of meteors. At some point several days into a new world we appear to hit a critical level of voxel damage that triggers some sort of reset or cleaning routine? We log out with the server just fine, the error never occurs with us on the server. We log back in to a broken server, with baby smooth skin - and the glitches described above.

Note: We have had this experience on 4 restarts now - so we've had it happen on Earthlike, Mars, Titan.

photo
3
photo
1

I'm new to SPE with around 200 hours in on a private server. This has happened twice now for me. Resetting the voxel map fixes the issue till we hit a critical stage and it happens. The first time the Voxel map was around 125MB. This time it's at 134MB which whilst anecdotal is a pattern.

photo
1

Once again like clockwork. Earthlike Voxel corrupted again.

photo
1

Yet another reset required.

photo
1

What did you reset if i may ask?

Im having the same problem and I am not sure what to delete and what not :D

photo
1

%AppData%\SpaceEngineersDedicated\Saves\<your world here>


EarthLike- <xxxxxx> .vx2


You'll need to overwrite the corrupt vx2 file with the vanilla one from a new world. I keep a set of vanilla VX2s on the "Saves" directory now in case I need to reset any of them.


My player group has been out in space for the last few weeks so the Earthlike has committed far less changes than normal but I also recently switched to using Torch software instead of the Vanilla server.

photo
1

Thanks, do you also know how to get a clean Earthlike.vx2 file? like can i make a new world and paste it in, assuming the world generation is the same?

Also wont replacing the file remove structures?

Btw thanks for the quick reply!!

photo
1

> like can i make a new world and paste it in, assuming the world generation is the same?

Yes.


> Also wont replacing the file remove structures?

Resetting the Voxel map doesn't affect the structures however any underground structures will be buried and have to be dug out if you want access to them.

photo
photo
1

I have the same problem, still no response from the devs here?

photo
1

I’m on Xbox on a Nitrado server and am running into the same problem. This is another of several bugs that have been brought up years ago… do they still work on this game?

photo
1

Hello!

Please submit a bug report on the Xbox page here: https://support.keenswh.com/spaceengineers/xbox/topic/add/problem

Kind Regards

Laura, QA Department

photo
Leave a Comment
 
Attach a file