Voxel Terrain Meshing/Generation Issue after patch/ES

SpikesSpace shared this bug 2 years ago
Outdated

Hey,

so im am going to make this as extensive as i can or at least try

Issue:

Voxels are in its origin form, as if the savegame/World was totally fresh. Holes from mining or underground bases aswell as impact craters generated by meteor storms on any surface are not visually there but physically. If you would try to mine it with a handdrill or a ship the Voxels stay in their original shape much as they were undestructable. However lets say you know a spot where a hole would be you can easily pass through the voxel, once inside you can basically dive right into the planet/asteroid with little to no resistence.

Occurence:

Started a new MP world on a dedicated vserver when the economy patch was released. Running smooth until 1.192.020 was released, updated the server as per usual.

After patching and restarting the server with no error messages the above described problem came to life. I was running 5min saves at that time. Went back and tried the recent 5 minutes autosave backups- all with the same result of the same problem persisting.

Thankfully i run full backups of the servers every day at 4.00 am - so the backup was about 8 hours old but it somehow just worked . Sidenote: Talking about full server image backups not savegame backup.

So i reverted to the 4am backup, patched again , started the DS again and voila working voxels.

After todays 1.192.021 update same exact thing happend again. Same recovery mode as described above worked aswell.

Save Info/World Settings:

Survival Multiplayer, Experimental mode, Ingame scripts enabled, Economy enabled, Voxel Gen 4, Auto Restart enabled, Save before restart (Watcher invertal 30s, min sim 0.05), -NO auto patching via DSM - NO MODS

my 2 cents:

I feel like the savefile gets corrupted while loading the save from patch a while the server is already on patch b. My inital thought was it might get corrupted when the autosaves happens, when shutting down , but i restarted countless times inbetween patchversion and all was smooth.

Replies (4)

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.


Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

This bug still occurs even where the map does not load properly.

When in such holes like as if the world does not generate underneath the voxel layer when you go through,

we got this for the last 3 months we tried everything we restarted the server several times, with all new and

even deleted the world to start all over and it kept happening every time.

Edit: We also got the same issues with meteors that hit the world, none of the holes show on the surface until you fall in one, and then it does not show the exit or the world beneath.

photo
1
Leave a Comment
 
Attach a file