This object is in archive! 

Mined voxels will appear filled in

theFipmip shared this bug 4 years ago
Solved

Currently playing on multiplayer server AU#2, and building an asteroid base.


To build the base, I need to dig out the asteroid. To do this, I get my drill and hold right click on the rock face to mine away the voxels.


I also have a space base sitting 70km away from the asteroid base. If I respawn at the space base, then die and respawn back at the asteroid base, the voxels I have mined appear to be filled in, but can be walked through like a hologram. This also reveals polygon holes in the asteroid. I can fix the problem temporarily by drilling near the filled in area, which will reset part of the 'illusion', near the drilled area, but not all of it.


Attached Images show the problem. bug1 and 2 show filled in, bug 3 shows how it should look.

Replies (7)

photo
1

Also as a addendum to this bug, this does not happen 100% of the time. There may be a difference between using left mouse and right mouse to mine, as some mined voxels in other areas on the same asteroid were not fillled in.

photo
1

It has nothing to do with mining.

Create a fresh world on a DS. Mine an asteroid with a basic on drill miner. Disconnect. Stop the server. Start the server. Reconnect. 50/50 chances of the asteroid being filled in where you just mined. From this point on the bug can happen.

Leave your ship inside the asteroid for extra bonus excitement.

photo
1

Meant to say method of mining.

photo
3

Hey guys,

we found the steps with 100% reproduction rate. We will fix it in next major update (v188).

Thanks for your reports.

photo
1

Next major? Isn't that like months away? Its really annoying trying to make a base inside an asteroid as sometimes it will hesitate when I pass though it, and it will make the sounds like I've hit it. My friend was able to see the asteroid as it should be (mined), but I still saw the voxels.

photo
1

This is why its unreasonable to leave it for so long:

https://youtu.be/y6Cvh61ejtA

As it acts as if the voxels are still there

photo
2

Agreed, I hope the next major is coming soon because this bug is annoying as hell. and has existed for a quite time (Since Planets were introduced I think?)

photo
2

I have found a fix. When i enable extreme voxel settings, wait a few seconds, then go back to high it seems to reset itself visually

photo
1

This issue should be fixed in Minor update v187.2

See the log: One of the predefined asteroids disappears when drilling the asteroid and reconnecting

Please let us know if the problem is really fixed.

photo
1

Visually it is fixed, but the server/client still thinks the voxel is there and affects the camera and you can still see the thruster 'interacting' with the air and creating dust. The voxels load in initially but disappear visually after a while. But now it causes crashes

photo
1

I take that back


https://imgur.com/a/l2EMD8y


If anything you've made it worse lmao. Now it crashes constantly


EDIT:

Im just gonna leave it, every time i try and move it it crashes...

https://imgur.com/Q6sKwcl

photo
1

Hi,

This issue should be tagged "solved" since it does not seem to happen anymore.

Running my own server, not a single report of this in months

photo
1

Still seeing this on DS multiplayer, earth like planet. Happens randomly. A new layer of visual voxels cover the actual voxels with collision. You, can walk, drive, fly through this new layer and crash into the invisible voxels with collision

photo
1

I keep having this issue again and again. Running my own DS. This is patch 1.189.044.

The whole game has tons of inconsistancy. The game needs to be coded in a way that is predictable.

This is the base of coding. Keen.

photo
1
photo
1

Happens on our DS. At some point all dug holes will appear as if filled in, but you can walk through the 'ground' that is now covering the holes. We run no mods. Only reloading an earlier backup will 'fix' it. It only seems to happen on the earth like planet though, on the asteroid base we have above the planet we haven't seen it (yet).

Replies have been locked on this page!