[1.194][DS] frostbite scenario game freeze every few minutes. (maybe weather?)

LordTylus shared this bug 16 months ago
Solved

Hello there,

I am currently trying out the new frostbite scenario and I noticed right after the cutscene that something is not quite right.

Apparently after like a minute the game completely froze, became non responsive and the window about closing the game popped up.

I restarted the game and tried again. About 10 minutes later same thing. This time however I left the game running and waited. With success. After about 25 seconds of nothing happening the game continued doing its job,

I have had 3 instances of that so far. And it appears that every time it happens the weather changed. So my assumption is it has something to do with weather change.

Sadly I dont know how to verify that.

Hope the logs can help figuring out the issue


I have to ask that I was able to play in Multiplayer and normal starsystem singplayer worlds for q while without issue.

Comments (15)

photo
1

I just checked it in an other SP with the /weather commands. and was able to switch between the different weathers without issue.


so it might not be weather related at all. Still weird that it freezes that often

photo
1

I have had the same issue, i also tried the other scenario and that crashed too.

Also the scenario sometimes crashes when loading it from a save game. I tested the weather by turning it to clear but it still crashed.

My feeling is something in the scenario is causing the lockup also i keep hearing a noise every now and then like im turning a console on and off again.

i have monitoired my CPU and GPU and they all seem fine but then the game locksup and all go to 0, i have a Ryzan 9 3950X and a Radeon RX5700XT with windows 10.

Please find attached a pic of the game with your stats in the top left also my graphics card in the top right at the moment it crashed. the crashes happen sometimes often others far apart and are all random in different areas.

photo
1

Ohh yeah thank you for pointing that out. I also hear these noises every now and then. I thought its sensors but they also appeared on the way up to the weather station. For no apparent reason.

photo
1

Deleted Space Engineers appdata folder and it worked for a while but then after about 20min it still crashed

photo
photo
1

Hi,I think I am having similar issue, my game keeps crasing at random times, and windows not responding window pops up. i have also notces this happening no only in forstbite scenario, but also in new empty world in creative for example. I have a ryzen 5 3600x and rtx2070s.

photo
1

Yeah just had it in an empty world creative scenario too.


Interestingly I am running Ryzen CPU too and all reporters so far run AMD CPUs maybe related?

New logs here:

photo
1

I am coming to the Ryzen CPU conclusion as well. Several other users on Steam have reported intermittent freezing as well as myself, sometimes on startup, other times they can play for 20 minutes before it freezes. Ryzen doesn't agree with something in this latest update.

photo
photo
1

Since this issue is pretty gamebreaking for me right now I used Visual Studio to Profile the whole procedure.

Had one taking almost 2 minutes just now

http://alehousegaming.com/diagsession.zip


there you can find the diagsession I took. Maybe it help identifying the issue.


Seems like it has something to do with drawing of strings


Inflex requested that I add my hardware spects as well, as it may be core count or / configuration related.


But as the logfile already shows

I am running an AMD Ryzen 3700X

Nvidia GForce 1080 ti

64GB of Ram


And here are current logs aslso

photo
photo
1

It's not unique to the scenario and also happens in any old survival/creative world. Seems to be an issue between SE and AMD processors, thread here: https://support.keenswh.com/spaceengineers/general/topic/becomes-unresponsive-occurs-quicker-each-time

photo
1

I trued to use The ModSDK SE build to profile in more detail what takes too long. But that one doesnt seem to have any issues.


But as far as I can tell that one ran without an issue for over an hour. Where the normal game doesnt even last 10 minutes.

photo
1

I also tried using The ModSDK SE files and it worked with out an issue so hopefully this will help the developers find the issue quicker.


The main game files seem to be the issue for AMD users.

photo
1

*edit*

Just realized commented in wrong tab.

photo
1

Game seems to work ok so far since new update

photo
3

I disagree still having issues

photo
1

You are Correct just took a lot longer to start seems fine underground for me but bad above ground

photo
photo
1

Confirmed still experiencing the same issue

photo
1

Got same issue. Ryzen 3600, 32GB RAM. Game eats about 6GB. Can it be GC pause? With such a large heap no wonder the freeze takes a while.

photo
1

from what i've been reading its an issue with their game not liking AMD. I have a Ryzen 5 3600x, 16 gb of ram, and radeon 590x which wayyyy more than what you need to play this game. Still freezes every couple of minutes. It didn't do this before. Very upset.

photo
1

If any one from support reads the comments is there any word on this as ive not been able to play the game since the update please some news would be nice

photo
photo
1

Same issue, but in my case it is not limited to Frostbite (just much more frequesnt there) and will unfreeze after couple minutes even if it got to the point of 'not responding' notification.

P.S. Ryzen 3800, 32GB

photo
1

Error Post

photo
2

I can't take credit for the fix, but it definitely provides results for me.


Go to your library on steam and find the tools tab. Find space engineers - mod sdk and install it. It's a free dev tool that Keen released to everyone. Open its folder and then open Bin64_Profile. Copy VRage.Library.dll. Now open your space enineers folder and paste this .dll in its Bin64 folder. Click yes to replace the existing one.

https://steamcommunity.com/app/244850/discussions/0/2259060348500655858/?ctp=2

photo
1

That does seem to work, but unfortunately partially for me. I still get periodic freezes, but no where as severe or as many.

photo
photo
2

Seems like these Issues are gone, now that the AMD bugs are fixed. So you may close it.