This object is in archive! 

Hydrogen Bug, hydrogen thrusters continue to work without a connection or all thrusters stop working

Muzzled shared this bug 6 months ago
Solved

Steps to reproduce;

Load an unmodified world in creative mode (for ease of testing, this works in survival).

1) Connect two hydrogen tanks with a conveyor.

2) Connect two hydrogen thrusters, one to each tank.

3) Observe them being functional.

4) Remove one of the tanks.


Depending on random chance (?) the thruster that was connected to the tank you removed will anomalously continue to function, or will cause the unrelated thruster to cease functioning. Attached are some screenshots showing the issue and the world file as a zip. It seems the entire hydrogen network will "choose" a particular hydrogen tank. If this tank is destroyed or removed the whole network will shut down until the grid is cut and pasted or the tank is replaced.


This issue scales up to larger ships, happens in survival, happens in single player, happens in multiplayer, happens on dedicated servers, happens after damage events with weapons, happens with modded weapons and thrusters. I appears to be triggered by using more than one port on the hydrogen tank. If you do not directly connect the hydrogen tanks via their resource ports the issue is more difficult to reproduce. You can use this bug to abuse hydrogen thrusters with hydrogen-at-a-distance if you're dedicated but its unlikely to be very useful.

Best Answer
photo

Hello, Muzzled,

thanks for letting us know about this issue! While it has been indeed successfuly reproduced - thanks for all the provided files - on the current version of the game, I wasn´t able to reproduce it on the new one.

Since we had quite a few other issues with hydrogen distribution and hydrogen thrusters, it seems that this issue was fixed with these as well.

So please, wait for next version of the game (v200) and try this behavior after the update. Hope your results will be the same as mine and you won´t be able to reproduce it neither.

Will close this thread as Solved now, since the issue is fixed and not reproducible on the newer version of the game.

If you still be experiencing it in any shape or form on v200, please let me know.

Kind Regards

Keen Software House: QA Department

Replies (1)

photo
1

Hello, Muzzled,

thanks for letting us know about this issue! While it has been indeed successfuly reproduced - thanks for all the provided files - on the current version of the game, I wasn´t able to reproduce it on the new one.

Since we had quite a few other issues with hydrogen distribution and hydrogen thrusters, it seems that this issue was fixed with these as well.

So please, wait for next version of the game (v200) and try this behavior after the update. Hope your results will be the same as mine and you won´t be able to reproduce it neither.

Will close this thread as Solved now, since the issue is fixed and not reproducible on the newer version of the game.

If you still be experiencing it in any shape or form on v200, please let me know.

Kind Regards

Keen Software House: QA Department

photo
Leave a Comment
 
Attach a file