screen saver / sleep mode

Bobby dazzler shared this bug 23 months ago
Need More Information

ok, so im playing/hosting a non dedicated server with a couple of friends, if im busy and have to go AFK i leave the game running for them to play. for some reason this game doesnt stop my screen from going to sleep (all other games will stay as i left them I.e PC state wont change no matter how long i leave it). that isnt the main issue though. Once i return and i move my mouse to wake the computer im met with a plain white box and its as if the game isnt even running. there is nothing on task bar and if i go to task manager it says the game isn't running even though it is as my friends are still playing it their side without any issues. the only way i can fix it is to exit steam, which disconnects my friends from the game, then after some time the white box will close enabling me to restart steam and then the game

Comments (13)

photo
2

i been having this issue for the last few months.


i turn off all power saving features both in windows and Bios. and SE still makes my Screen go to sleep.

photo
2

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
2

I have this same issue. I find that when it happens the only way i can close space engineers is under task manager. The game no longer has a button on task bar and is not in the top portion of the task manager for running programs. Itstead I find it well down the list in the "Processes" section. When this happens, Alt-Tab will not even recognize the game as running (since it has been converted to a process instead of a program running).

photo
2

I have had the same issue as the op for over a year, it's somewhat refreshing to see newer reports of this issue... and somewhat depressing as well. LOL!

photo
1

Hello, All!

I appreciate this thread is quite old. Is this still a problem that persists for you or has this been resolved? We have had a number of updates since your post and are now on 197.180 so this may have been resolved. Please let me know and I can close this for you if required :)

Kind Regards,

Laura QA Department

photo
1

Yeah it still happens occasionally, but less often since then

photo
photo
1

Yes this still happens for me on most recent build. I tend to not go away long enough for it to happen much anymore. It can still happen if I alt tab out to look at a webpage or something but not every time.

photo
1

Hello, David!

Thank you for confirming. Is this within Windows 10 sleep function? E.g. 25 minutes it will go to sleep? Once this has then gone to sleep, do you leave it a lot longer than the 25 minutes and then it is an issue? Any further information would be a huge help :)

Kind Regards

Laura, QA Department

photo
1

I do run windows 10 but I have disabled the ability for the system to go to sleep. I current let it turn the screen off after one hour. It seems to be tied to the game losing primary focus. I will try and reproduce this later when at my home computer but its very rare. Last time I remember it happening I had left the game running and had to step away. About an hour to hour and a half later when I returned i moved the mouse to turn the monitor back on and there was a white box in covering about 1/3 of my screen while the space engineers music was still playing and there was no way to get to space engineers and continue playing. Steam said the game was running and in task manager, space engineers was no longer listed as a running application but instead as a background process with no option other than ending the process.

photo
1

Hello, David!

Thank you for providing more information on this. I had tried my PC set to sleep yesterday but it didn't result in any issue. Now that you have mentioned the screen turning off, I will test this and see if I end up with the same result :)

Kind Regards

Laura, QA Department

photo
2

Hi, I get this all the time, I literaly can switch monitor off for 10 seconds and when I turn it back on the screen is white. I then have to close Space Engineers down through Task Manager before I can restart game.

Display is set to

Fullscreen, 3840x2160 - 16:9 using a NVidia RTX 2080 Super

Screen Size multiplier x1

Vertical Sync - Not enabled

Capture Mouse - Enabled

All the graphics settings are on max.

photo
1

Hello, David!

Could you let me know if you share anything in common with Matthew here? (thank you Matthew!)

Just in case for example you're both playing in 3840x2160 or something that may help us narrow down the cause here. Turning off my monitor isn't having any effect on the game with my current setup annoyingly.

Kind Regards

Laura, QA Department

photo
1

Last time I experienced it I was running 1920x 1080 resolution (16 x 9) on a NVIDIA GTX 1070 in full screen mode.

Graphics settings were not maxed as far as I remember. I have gotten in the habit of saving and exiting to main menu or even exiting the game completely when i have to step away so it has been a bit for me. I have also upgraded hardware since then but will try to see if I can replicate the issue later today. If I can I will see about attaching the log file.

photo
1

Ok I was able to duplicate the issue just now.

I entered a vanilla unmodded worlds and played around for a few minutes (5 to 10 minutes). I then turned off my monitor. After about 10 seconds or so the game sound changed volume, so I turned my monitor back on. When it began to display a picture again, I saw that the game had white screened on me and i had to shut the game down via the task manager. I have attached a screen shot with task manager showing space engineers running (its in the background processes portion of task manager) and the task bar at the bottom of the screen has no block for space engineers which is the white screen behind the task manager. Also attached are both game logs from this session.

photo
1

Hey Laura, thanks for the help! Yeah this issue still plagues me, playing on 1920x1080p with a GTX 1660X, it used to sometimes break and white-screen when alt+tabbing, but that no longer happens. Now if I let my computer fall asleep or leave the game idle for ~20min it will "minimize" itself and disappear into the white screen.

photo
1

Hello, All!

Thank you so much for the information. I'm still struggling to reproduce this. It seems some of you are having the issue by simply turning the monitor off and some by letting the PC fall asleep? Could I please ask what sleep settings are being used? Just to help me try to reproduce the issue. I have tried turning the monitor off, unplugging the second and then turning the first off. I have also tried letting the PC turn off after a few minutes but still nothing. Is everyone running a single monitor or dual? (or even more!)

Kind Regards

Laura, QA Department

photo
1

I run a single monitor (ASUS 27 inch at 2k resolution model VG27AQ1A). Under poer settings, i have monitor set to turn off anfter 1 hour, computer set to sleep after never, and performance slider set to best performance.

Otherwise for hardware, im on an amd ryzen 9 5900x, geforce rtx 3070, 32 gb ram, and asus b550-e motherboard. All running latest drivers and most recent bios on motherboard.

photo
1

Detail of windows settings and monitor info listed in screen shots.

I'm running i7-7700k 64gb ram on ASUS TUF z270 mark2 motherboard, Single monitor

photo
photo
1

Hi there late back to the party sorry. I hadn't played the game in a while but came back to it about 8 weeks ago. Played it for roughly a month and haven't now for about another month. I didn't notice that the game still causes the original problem tbh. There were a couple of times I left the game running then came back but it seemed ok.

For what it's worth. I'm running on a ryzen 5 1600 with a gtx 1080 , 16gb of ram. Dual monitors, first is a 28 inch 1440p at 144hz second is a 32 inch 1080p running at 60hz. First using display port second using hdmi. All drivers/software up to date.. power settings on performance, pc never sleeps. It's either on or off

Hope that helps

photo
1

Hello, All!

I really appreciate everyone's input. I just wanted to let you know that I am still trying to reproduce this issue and taken everyone's information onboard. I was hoping to see something obvious in common but can see a range of monitor counts, GPU's etc. I will keep trying to reproduce this but you're not being forgotten :)

Kind Regards

Laura, QA Department

photo
1

Wow this happens with me too sometimes if it shuts off screen. My settings are 3 min to turn off screen and 5 min to go to sleep.

I use two screens, resolution 1024 x 768, 8 GB ram, and the GPU is GTX 745 refreshing at 60 Hz. Both monitors are the same 15 inch LCD displays with standard dynamic color range. Drivers aren't completely up to date but I'm updating them now and will see if that changes anything

The processor wouldn't have anything to do with it, right?

photo
1

Could also just try a different computer to reproduce it on, though that's just me throwing out ideas. My computer's pretty old--I bought it in 2015. I also tried to reproduce it on a much newer computer that my little brother uses and the bug didn't happen, so maybe it has something to do with the computer's age? Then again, that computer never went to sleep (and I don't know if that's because it uses only one monitor...?).

photo
1

I don't think that's it, I have a brand new PC built in 2020, and I still get this bug. Whenever my PC goes into Sleep Mode SE still white-screens and disappears from Task manager for a few minutes.

photo
1

Interesting... Did you look in background processes? Sometimes Space Engineers goes there for some reason for me, although other times it disappears altogether while Steam appears unusually resource-heavy and closing it gets rid of the white box.

photo
photo
1

I haven't experienced such bug in SE but I do believe I know what might be the cause of it.

You see when your computer is inactive for some time (no input from user) it goes into power saving mode. It does this by preforming several steps like throttling down the CPU or even powering down some of its cores. It also powers down the graphics card. This you can detect when your monitor looses the signal and goes into its own Stand-By mode.

And the latter is what is causing this problems. Why? When graphics card is powered down all render surfaces gets destroyed. So when you come back to your computer the game is still trying to render to rendering surfaces that no longer exists.

Now there are two way to prevent this.

One is to notify Windows that application require display to be always on using SetThreadExecutionState WIN API

https://docs.microsoft.com/en-us/windows/win32/api/winbase/nf-winbase-setthreadexecutionstate

Another is for SE to properly detect when graphics card goes into power saving mode and when it wakes back up so that game can recreate the needed rendering surfaces. How this is achieved depends on which rendering API the game is using (DirectX or OpenGL).

First solution is much easer to implement but it might lead to Screen Burns. That is why some of the games that do rely on this feature also include their own "screen saver" which makes sure that image on the monitor keeps changing. For instance some games hide the UI and enable a sort of cinematic camera that constantly moves around and thus prevents static image being shown on the monitor.

photo
1

Hello, All!

I've been back looking into this again and trying to see if anyone on the Steam forums experiences this with another game as I still am unable to reproduce the issue here. I have seen that some Windows 10 users experience it on the screen itself rather than an application and the suggestions there were to check graphic drivers and also check drivers in the display adapters. Quite a long shot on both these two but would appreciate you trying and seeing if this helps at all. Sorry that I haven't had a cure for this yet.

Kind Regards

Laura, QA Department

photo
1

Hello, Engineers!

This is a huge long shot but are any of you using Bluetooth keyboards or headsets or anything that may disable or go to sleep at the same time at the monitor? We have an ongoing thread where headset disconnections are causing issues and someone also mentioned a Bluetooth keyboard. It's just a thought that something else may be interfering but as I say, quite a long shot!

Kind Regards

Laura, QA Department

photo
1

No I do not use any blue tooth devices.

photo
1

Hello, David!

Thank you for confirming, I thought it was a long shot but I appreciate the quick response :)

Kind Regards

Laura, QA Department

photo