Immediate Crash on Startup of Game

Eidolon Wyrm shared this bug 9 months ago
Won't Fix

To reproduce:

1. From Steam library, click "Play" for Space Engineers.

2. The game starts to load normally to a black screen, then the cursor for Space Engineers appears.

3. Game crashes to desktop without loading anything else.

Troubleshooting so far:

1. Verified integrity of files through Steam.

2. Checked and ran Windows Updates.

3. Restarted PC.

Best Answer
photo

Hello, Eidolon!


Thank you for your information so far. Some players have fixed this issue using this workaround if you are willing to try it:


  • Add -skipintro into the game launch options
  • e85fc09208b68680cbcd2eda56e923f4
  • Renaming / Deleting "\Steam\SteamApps\common\SpaceEngineers\Content\Videos" folder


Kind Regards

Keen Software House: QA Department

Comments (18)

photo
1

Also just tried disabling the Steam Overlay but no change to crash behavior.

photo
1

Description
Faulting application name: SpaceEngineers.exe, version: 1.0.0.0, time stamp: 0xe7b0c562
Faulting module name: KERNELBASE.dll, version: 10.0.19041.804, time stamp: 0x0e9c5eae
Exception code: 0xc0000005
Fault offset: 0x00000000000280d9
Faulting process id: 0x2d20
Faulting application start time: 0x01d700c13b41b23e
Faulting application path: R:\Games\Steam\steamapps\common\SpaceEngineers\Bin64\SpaceEngineers.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: 9745844a-1527-41bd-9ee5-e940bfb443b9
Faulting package full name: 
Faulting package-relative application ID: 
From event log. Running a system file check now.

photo
1

Scan complete. Multiple corrupted files detected. Might be a problem on our end, not yours.

photo
1

Game still crashed after restarting PC after files repaired. Here's the log.

photo
1

Revalidated files one last time... Still crashed. Here's another log. I'm not even gonna try.

photo
1

Hey, I've posted this same bug here about 18 hours ago, so this is a duplicate. Please upvote my issue so it gets fixed! Thanks.

photo
2

Hello, Eidolon,

we´re sorry to hear you have such issues.

Please try as well following in order to fix the crashing of the game:

  • Delete SpaceEngineers.cfg file
    It means your game configuration will be deleted
    You can access your SpaceEngineers.cfg by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers.
  • Delete ShaderCache folder
  • Back up your whole Space Engineers Roaming folder and delete it
  • Restart Steam
  • Reinstall VC Redist 2017
  • Update graphic drivers
  • Reinstall the game

Let me know if any of provided solutions worked for you, please. Or if you observe any change in the game behavior (e.g. crashing on different place... ).

Hope some of the provided solutions would work for you.

Kind Regards

Keen Software House: QA Department

photo
1

The first 2 did not work. Currently re-installing space engineers.

photo
1

Everything other than updating graphics driver has been done. No change in glitch behavior.

Might have to resort to that other solution somebody had to a similar problem a few months ago.

Editing registry.

photo
1

Can you link me the solution you're referencing? (the registry one)

photo
1

I can't but i have the message that i got the idea from itself:

Chris ● 3 days ago FIXED Somehow steam was defining my game library folder as "c:\progra~2", rather than "C:\Program Files (x86)". None of my other games have a problem with it, but SE did. I simply stopped steam and changed every reference from 'c:\progra~2\steam' in my registry to "C:\Program Files (x86)\steam". (There are also some using the opposite slash, ie "c:/program files (x86)/steam" that I changed as well. SE then loaded and ran properly.

photo
photo
1

I have done everything other than registry. Nothing changed.

photo
1

Turns out registry was not the problem. Keen, turning control over to you.

photo
1

Hey, please try and see if the workaround suggested in this post solves the issue for you.

photo
photo
1

For who has this issue, Antti Koponen found workaround solution , you can find it in his post

https://support.keenswh.com/spaceengineers/pc/topic/critical-v1-197-1-game-unplayable-crashes-to-desktop

photo
1

i had the same issue. got it to work by making another windows user account.

photo
1

Hello, Jurgens!


Thank you for your information. A corrupt windows user profile is a common source of this error. I'm glad that it helped you!


Keen Software House: QA Department

photo
photo
1

I'm not looking to get this solved individually anymore, but rather provide the information for Keen Software House to fix it, so that everybody else do not have to deal with this serious problem.

photo
1

Hello, everyone!


Thank you all for the information. We're sorry to hear that you're experiencing issues.


Before taking any of the steps below please make sure that your PC meets the minimum system requirements:


https://www.spaceengineersgame.com/system-requirements.html


The kernelbase.dll crash occurs in a wide range of games and apps in general. The crash isn't typically caused by Space Engineers and may be the result of a system issue. Hopefully, we can provide you with a solution to your issue quickly. However, we may not be able to address your issue until a future update or hotfix to Space Engineers.


In the meantime, please take the following steps:


  • Update Windows (The most recent update for MS Windows 10 is Microsoft Windows NT 10.0.19041.0)

  • Update your graphic drivers

  • Reinstall the Visual Studio redistributable: download the latest version from the official Microsoft website (x86: vc_redist.x86.exe OR x64: vc_redist.x64.exe)

  • Run as a different user (a corrupt windows user profile is a common source of this error)

Please follow these steps and let us know if it helped you. Thank you.


Kind Regards

Keen Software House: QA Department

photo
1

1. I am in my latest version of windows

2. I already updated my graphics driver

Visual studio and a different user is something i have not tried yet, I will let you know if it works.

photo
2

Thank you for letting us know!


Kind Regards

Keen Software House: QA Department

photo
1

Somebody else noted a common trend of GTX cards, just also letting you know.

photo
1

At this point, I'm not even gonna try. I have other intrests now, but the game is good. Aside from mod.IO

photo
2

Hello, Eidolon!


Thank you for your information so far. Some players have fixed this issue using this workaround if you are willing to try it:


  • Add -skipintro into the game launch options
  • e85fc09208b68680cbcd2eda56e923f4
  • Renaming / Deleting "\Steam\SteamApps\common\SpaceEngineers\Content\Videos" folder


Kind Regards

Keen Software House: QA Department

photo
photo
1

Hello, Engineers!

Are you still experiencing this issue? Have you tried suggested steps? Did it work?

Thanks for letting us know.

Kind Regards

Keen Software House: QA Department

photo
1

i had the same issue, tryed the -skipintro and deleting videos and reinstalling VC destro latest, and updating windows and grafix drivers but the only thing that worked was making a new windows account and logging in. t is related to that registry point that someone had already mentioned above.


thanks for sharing any new info of why this is happening and haw to get it fixed from the root

EDIT: i found an easier solution, it has nothing to do with code editing or complicated regediting, after lotst of digging arount and experimenting you can simply go to the spaceengineers folder in Roming directory and copy it all to a safe location then delete it, then restart steam restart space engineers it should work (with -skip intro and video folder deleted) then exit game, exit steam, put back all the files you saved in safe place to thier original folder EXCEPT shedarchach. start steam, start game , you will find your games and mods all where you had left them!

photo
1

Hello, Engineers!


Because there is no new comment from you, and we are unable to reproduce the issue on our own, I will close this thread now as outdated.


If you or any other player will experience this issue again, please make a new thread and provide all needed info there.


Thank you for understanding.


Kind Regards


Keen Software House: QA Department