Crash to desktop on official server join

Mythos shared this bug 6 months ago
Duplicate

There is a heap of similar issues reported here, none of them to a final satisfying conclusion. Either support can't offer any help, or the player never responds, probably because he quit SE because of this. I also can't oversee all the various entries and possible nuances. So I'll try to add my experience to that with a new entry here:


Every time I join official server DE#5 the game crashes randomly in one of those

- display welcome message, hear some sound (access denied, not sure), crash to desktop, no message

- crash to desktop even more instantly, no message

- crash to desktop and show "overheated" message

- crash to desktop and let me send error report

- game not responding and needs to be killed

- devastating OS blue screen (dxgmms2.sys)

On this instance the error seems to be really persistent and restarting my PC or clearing the shader cache (as suggested here https://support.keenswh.com/spaceengineers/pc/topic/23404-game-crash-while-joining-multiplayer-with-graphics-on-high-single-player-works-fine ) does not help.

While the problem persists on DE#5 (I just started and need to respawn in a small scene), I can totally fine join DE#6 (in cryo, much more complex scene with sophisticated stuff and multiple team member grids around). And as usual single player works, too. Having those two similar official servers behaving differently must tell some dev about the origin of that problem (spawn vs. cryo?).

I did encounter a similar problem on DE#6 as well, occasionally. Usually when being in cryo as opposed to the current situation. Also it then usually does help to reboot my PC or disable/reenable my graphics driver. Once a friend told me it also helps, if he would grind me out of my cryo, and it actually did (still opposed to the current problem without cryo).

The offical game server admins won't help to solve the problem but point me here. So what can we do about it?

Replies (3)

photo
1

Hello, Mythos,

thanks for letting us know about your issue and we are sorry that you are experiencing it.

However, I seems not to have any issue when trying to connect to the mentioned server. Also other players are there, connected properly and playing. So I guess the issue must have be in your local game file/data.

We provide these steps to ensure that the player has the game and other needed programs in working order:

  • Verify your game files in Steam – right click on Space Engineers in Steam Library → Properties → Local Files → Verify Integrity of Game Files
  • Delete SpaceEngineers.cfg file (it means your game configuration will be deleted) – you can access your SpaceEngineers.cfg by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers.
  • Delete ShaderCache folder – same access as above
  • Back up your whole Space Engineers Roaming folder and delete it
  • Restart Steam
  • Reinstall VC Redist 2017
  • Update graphic drivers
  • Reinstall the game
  • Make sure your operating system is fully updated

It's possible that none of these might work for you. Since both your logs you provided, have this same error "ERROR: Camera entity from checkpoint does not exists!", there is a workaround/fix from pleayer mentioned in a other thread:

Try setting the following in Sandbox_config.sbc in the world directory:

Next what you can try, that helped to some players is: locate your Sandbox_config.sbc file in the the world directory (if you are admin and/or have acces to word saves). There you would need to set the following:

find the lines that are saying: "StartInRespawnScreen" and set it to true and "EnableAutorespawn" and set this one to false.

(these options likely already exist in your config, so make sure to update them, not duplicate them).

There is a downside of this as using this method you will respawn each time, so if you have inventory you will lose it, even if you're in a cryopod.

But since you also have error: "Warning: Server failed to update game inventory items." that would happen anyway, I guess. This method might only work for lobby/dedicated server game, though.

Please let me know if anything from above worked for you.

Is this issue persistent for you and you are not able to join there at all? Or some times, it's fine joinint there, while other times you get these issues? Are you the only one experiencing this? Are your friends/other players that you know able to connect without issues?

From our current knoledge, this issue is more likely to happen, if you log-off the game near big voxel changed area (big holes dug in asteroids, planets etc.), so please, if you are able to connect from time to time, try to log-off in a space, rather far from any player changed voxels.

Hope something from above would work for you.

Kind Regards

Keen Software House: QA Department

photo
1

I'm also having this problem currently. Build 1.201. The first time I boot up my game and attempt to connect to Keen Server #6 via "Continue Game" it crashes to desktop during loading of the server world. Booting the entire game again and Continue-ing again seems to fix the issue. There is no option to report the bug, so it's a pretty severe crash. It's absolutely lights out straight to the desktop.

photo
1

Hello, Engineer!

After investigating this issue, it seems that this issue is a duplicate of this.


However, we are still not able to reproduce it.

I will mark this thread as duplicate, as we are trying to have only one open thread per issue.


Please read through the communication there and if you have something to add, please write a new comment there.

As for the resolution of your issue, also keep an eye on the said thread for any new information, comments, and possible fixes coming.


Kind Regards,

Keen Software House: QA Department

Replies have been locked on this page!