[publictest] Bug with sound

CdriX shared this bug 18 months ago
In Progress

I have a bug with the sound, it appears just during the game (not in the main menu) like the sound of a bee (sorry for my English). I try to verifying files with steam but always the same problem. All my drivers are updated and never had this problem before on the game

Comments (19)

photo
2

this might be the new wind sound- I had a hard time understanding it myself- the sound seems to match that of a bee, especially when using bad headphones or my desktop speakers. a little tewaking to the sound may bring it back to what it is supposed to be.

photo
1

here a short video clip with bug sound

photo
1

I have exactly the same issue...

photo
photo
2

Lovely audio bug on mine, sounds like someones only half plugged in an audio jack.

Checked my setup with another game and its okay, just ME that's being weird C:

AMD processor BTW

photo
2

Same bug

photo
1

I found something about the bug sound, in your sound settings, put all the sounds like my picture and after that, you have just the sound with music.

photo
1

The game is doing a lot more with audio filtering, mixing, and bitrate conversion than it used to. We found a few interesting ways to break direct 3d audio while we were working on it. So this is not the first audio bug we've heard. However, it seems to be working correctly for most players so we can only assume this is related to specific settings, drivers, or hardware.


We're looking into it but it might help if you can share your audio information and settings. Whatever you can give us will help. If you are comfortable sharing detailed information publicly you can share a DirectX diagnostics report.


To get the DirectX Diagnostics Report:


  • Open the start menu (or start screen) and type dxdiag. Press enter.
  • Click the Save All Information... Button to save a text file with the information
  • Attach the text file to your reply

  • If you are not comfortable sharing it publicly, you can click the Request Help tab above and send it in a support ticket. Please use "[publictest] Bug with sound" as the subject if you choose to submit your report this way.


    Thank you for your assistance with improving Medieval Engineers!

    photo
    1

    Here my DxDiag ;)

    photo
    1

    Here is mine:

    photo
    2

    Same problem. I have a G633, I switched to 3.5mm and the problem was resolved. This suggests the the problem lies with the USB side of things, probably the audio driver.

    photo
    1

    Okay, here's a weird thing. I have both the 3.5mm and usb plugged in. When I switch audio sources to the audio out source to be Realtek, I can use the 3.5mm just fine, which I just posted about.BUT! When I switched back to the Logitech driver, the game audio is sent on both Realtek (3.5mm) and Logitech (USB) on the headphones (I have a video playing in the background that only plays over the default sound selection in window's audio settings), and in BOTH cases, the audio is now perfectly fine, but only while the 3.5mm is plugged in. Hopefully this helps, or can be used as a workaround in the meantime.

    photo
    1

    for information : software version Logitech 98.3.27 (up to date). Gaming headset with usb connection


    I had the same problem with farming simulator 19 (not bug with bee, but no sound). Devs should fix this bug with an update specialy for Logitech !

    photo
    1

    Magnymbus I think you might be on to it. I didn't find anything conclusive in the logs and they say it happens everywhere. You guys have different hardware and drivers so that leaves only settings in my mind.

    Could you post some of your settings? You can use Alt+Print Screen to screenshot a single window like this. Then paste it into paint and save. The settings in this screen could bear on the problem

    b878912a1bcfe2ad03024f314e510a4f

    What is your speaker setup?

    14a90597f2f015bd37f16181ea3c6369


    Also try turning off Enhancements and Spacial Sound to see if it makes a difference.

    photo
    1

    Since my sound works as expected on the myriad of other games I have, I'm assuming that this is a ME bug.

    photo
    1

    I tested multiple sound devices and it is happening only with the Headset (Realtek High Definition Audio) device in the DxDiag file. The sound was good with:

    MG248 (NVIDIA High Definition Audio)

    LINE (MG-XU) a Yamaha Mixer sound interface

    photo
    photo
    1

    Hello,


    Seems like a very odd issue to have. Are you using headphones? Are all you sound drivers up to date? Just trying to see any connection between your issue since they are similar.

    photo
    1

    All my drivers are up to date, always ! I use a gaming headset only. I play at a lot of games and never had problem with the sound.

    Before this public test branch, any sound problem with this game too.

    photo
    1

    I post these files too if it can be help you

    photo
    2

    i get a metal hum sound when my engineer is walking, like the footsteps...

    photo
    1

    Are you guys playing in the safe area?

    Those logs have quite a few crafting errors in them and a lot of broken deer. I guess what I'm asking is, do you have this problem if you create a new empty world (not the safe area)?

    photo
    2

    no the bug sound is everywhere (safe area and outside safe area). I tested in local and multiplayer mode. I tested in empty world it's the same ... bug sound.

    photo
    2

    Before this sound bug I usually hear wind sound when I fly high in creative mode. Now I don't hear wind sound, maybe related to it?


    Inside or outside of safe area no difference.

    photo
    2

    Having the same issue. Only on test branch.

    photo
    1

    Here's my DxDiag too, using a Corsair HS70 headset.


    Edit: was meant to be a new comment :p

    photo
    photo
    1

    I have had the same bug, it is associated with the location of the ore vein in the ore refining quest; as soon as the horn ( or what used to be the horn) sounded, the sound ( like r2d2 snoring or my jack got underwater or something) came from nowhere and persisted untill I picked up a stone on the ground. The new sound of the stone being picked up fixed the issue for a while.


    UNTILL

    I walked back over the same spot where I had first gotten the strange sound ( the marked ore vein) and it came back!


    Apparently the location of the quest or the ore is causing the issue for me.

    This occured in singleplayer and outside a safe area

    photo
    1

    Is anyone having this issue with their speaker setup configured for stereo? ...or is it only surround configurations?

    photo
    1

    I don't use the surround setting, but that doesn't mean that the audio isn't being processed that way before being sent to the headphones, in fact, for the on the fly switch, I'm guessing that's exactly what's happening.

    photo
    1

    and it's strange because at the main menu of the game, don't have this bug

    photo
    1

    The main menu is stereo, not 3D positional sound. So is the music, ambient environment sounds, and "HUD sounds". Only the "game sounds" are 3D. Basically, any sound made by a block, player, or impact, that can be heard by others.


    Can you confirm if this is only an issue with 3D sounds? Is the music ok? This would be a 3D problem.


    My current working theory is that this is a bitrate related problem. Like you attach a high bitrate USB headset and the game detects it on startup and uses higher bitrate sounds and there is some problem in the pipeline. If you attach lower bitrate analog speakers, then the game uses the lower bitrate and everything is happy.

    photo
    2

    For me, music is ok (main menu and ingame too) ! It's a problem with ambiance environnment sounds, when the character is walking, jumping ...

    photo
    2

    Yes, music is ok.

    photo
    1

    only 3d sounds are effected, but the bitrate on both the logitech and realtek devices are both 16bit, 48000Hz

    photo
    2

    I've tried 24 and 16 bit. There is no difference. The bug persists.

    photo
    1

    I'm having this issue with a 2.1 stereo w/ subwoofer

    Changing bitrate and bit format doesn't fix it


    edit:

    Having the bit format set at 24 bitrate set at 192000 Hz lowers the sound of the buzzing sound when walking, jumping, and any other interaction

    photo
    photo
    1

    before folks chase their deep windows sounds settings, answer this please - is the beta test using the same parameters for sound as the regular version? i switch between the two, sound is great on the regular server and we never had to chase the bitrate etc.

    photo
    3

    I switched back to the older version. The sound is fine there, so it seems to be a new bug.

    photo
    1

    Our audio has changed a lot in 0.7. Because there are so many changes, we're still trying to track the cause of this issue. What I'm looking for is anything specific that you guys have in common that will point us in the right direction.

    photo
    1

    RealTek compatibility is the issue. I've downgraded drivers and now I am running the most current. Is in on Keen's side with compatibility somewhere. Hope you guys get this fixed,

    photo
    photo
    1

    I tried my headphones, sound bug is still here. (Normally I use 5.1 speakers.)

    photo
    2

    I recorded a video about the sound bug for you to hear: https://www.youtube.com/watch?v=5pqF2AKkBjw

    photo
    1

    ^^^^^ exact same sound as with mine

    photo
    1

    That's rather interesting. It's like your reverb settings are incorrect.

    Can you open Ctrl+F11 and press R to see the reverb settings, please? You might need to use Steam or something to make a screenshot. The game tries to ignore debug displays when it makes them.

    photo
    1

    Here:

    photo
    photo
    1

    I have the same bug. only in 5.1 mode though. If I switch to stereo it works fine. Playing on the released version.

    photo
    1

    Same as above,

    "Can you open Ctrl+F11 and press R to see the reverb settings, please? You might need to use Steam or something to make a screenshot. The game tries to ignore debug displays when it makes them."

    photo
    photo
    1

    Funny thing happend to me, I was taking a screen shot for a bug report and decided to alt-tab to work on submitting it- and the Steam screenshot sound only played when I whent back into the game, the game was actually delaying the sound as if it where in game by a whole 10 minutes since when i took the screenshot, mabe this will help.

    photo
    1

    Interesting, but it might be unrelated. You can try disabling the Steam overlay to see if it makes a difference. I personally don't use it and I had fewer issues than my colleagues during the audio development. I never did figure out why.

    photo
    photo
    2

    I have the same exact sound issue. The hammer hitting, walking, thuds from landing when jumping, breaking down a block, exiting and UI, the sounds are super distorted. My sound card drivers are up to date. Brand new computer I just built, no issues in any of your games or others. Looking thru the logs I see an issue Pastebin 2nd issue is I have another similiar pc with the same issue. It might be RealTek and compatibility with them. I have an AMD Threadripper 1950x on other pc and a Ryzen 7 on this.


    Please guys, could you check %appdata%\MedievalEngineers and look thru your MedievalEngineers.log file and see if you all have those audio error logs where those are the specific ones being over distorted. I am pretty sure it is not our hardware. Definitely a bug on their end.

    photo
    1

    Here's my screenshot.

    photo
    6

    Hey Guys, I have an announcement!!!!

    The trouble with the sound seems to be coming from the DirectX filters we're using. We have no idea why the built-in filters would cause trouble but we'll leave that to Microsoft to figure out. We're going to add a setting to our audio options to disable advanced sound features. This will disable all filtering and reverb which should eliminate the issue for you guys.

    Look for a checkbox in the next update, which should be a hotfix later today.

    photo
    2

    Great!

    Hope you will fix it soon so we won't have to disable it.

    photo
    2

    Medieval Engineers 0.7.1.649EB1

    photo
    1

    Thank you so much Keen for the quick fix !

    photo
    1

    I have Realtek audio drivers on my laptop that can do a lot of the 3D positional sounds if enabled. I sometimes use this for other games. How is the 3D sounds in ME different from that? Is it necessary to make it an in-game default if it can be enabled through the audio drivers as an option?

    photo
    1

    ME uses XAudio2 which is distributed as part of DirectX. This is the industry standard for DirectX based games.


    The only mention of anything like this that we've been able to find is in a World of Warcraft forum post from 2011. In this post, someone suggested the issue could be caused by Microsoft's drivers not splitting audio to multiple outputs properly. That person suggests installing appropriate audio drivers from Realtek.

    As I have found multiple PC's in the office over the years that never had the basic motherboard drivers installed, it doesn't surprise me that there could be issues. If you built your own PC or didn't get it from a reputable OEM, you should have installed some audio drivers at some point. Likely these came on a disc with your motherboard. If you skipped this step, you may want to give it a try.

    photo
    photo
    1

    One person suggested that this is a bug related to windows 7 can anyone confirm that they have the bug and not Win 7?

    -i have the bug, and windows 7

    photo
    2

    I have Windows 10 Pro as well as Windows 7 Pro and Windows 7 Ultimate, it is a DirectX issue for all OS's or faulty Keen API code working alongside with DirectX. For now hit escape > Options > Audio > Uncheck "Enable Advanced Audio" and all the wacky audio problems should cease. BF5 and Shadow of the Tomb Raider with 3d audio all work perfect via DirectX.

    photo