This object is in archive! 

Rotors will not move

Paul Thompson shared this bug 16 months ago
Solved

Xbox one X ,retail version experimantal mode, map lone survivor. Small grid.

Place 1 rotor set it up add blocks. hit reverse nothing happens move the displacement right along min max or max min, rotor moves, once stopped hit reverse same issue need to move displacement right along min max to start rotor. i have tried several rotors with same issue advanced and normal.

Best Answer
photo

Hello, I think i sorted it, it was down to the inaccurate collision boxes on the half blocks, and wedges it appears even if there is a gap the rotor thinks it is blocked, i deleted all blocks around rotor and now works fine, however it looks quite ugly with large gaps, any way of taking a look at collision regarding those blocks when interacting with rotors and pistons as this maybe a big cause for clang effects, cheers and keep smiling you are doing a mint job

Comments (2)

photo
1

Hello, Engineer!


Unfortunately we are unable to reproduce the issue. Are you sure velocity of your rotor isn't 0? Because rotor can't reverse if it does.


Kind Regards

Keen Software House: QA Department

photo
1

Hello, I think i sorted it, it was down to the inaccurate collision boxes on the half blocks, and wedges it appears even if there is a gap the rotor thinks it is blocked, i deleted all blocks around rotor and now works fine, however it looks quite ugly with large gaps, any way of taking a look at collision regarding those blocks when interacting with rotors and pistons as this maybe a big cause for clang effects, cheers and keep smiling you are doing a mint job

Replies have been locked on this page!