Angled Hinges out of position and exploding or destroying subgrids when reloading game

Paul Thompson shared this bug 3 months ago
Won't Fix

I have found when making hinge joints that if you leave the game or copy paste the build with the hinge at an angle normally 90 degrees, the hinges will either explode or destroy the subgrid when pasting or reentering the game, the only safe way around this is to make sure all joints are at 0 degrees when exiting game or copying build. this is not ideal as some joints need to be at an angle.

Jump to 3.20 on this vid to see an example of the mechanism. https://www.youtube.com/watch?v=zxYI5wwuL7U if i leave the game with that inside the arm and reenter, the mechanism has attempted to unfold inside the arm, yet as you can see in the whole video the mechanism is sound within the arm during all the movements.

Comments (6)

photo
1

Hello Engineer,

unfortunately we couldn't reproduce the issue on our side. Is it happening on single player, on dedicated servers? Could you upload a blueprint of one of the grids that's causing issues to mod.io and share the link?

Any additional information would be welcome too.

Thank you.

Kind regards,

Keen Software House: QA Department

photo
1

OK blueprint for a mech that has this issue https://spaceengineers.mod.io/auto-drill-mech2 instructions in singleplayer retail or Beta on xbox one x, cockpit at the top has control panel right hand side , press the squat button to put mech into squat position. copy mech and paste it, it will explode, in squat position also leave game, when reloaded the mech will explode. here is a vid of it happening https://studio.youtube.com/video/fBHwPopV9HE/edit

photo
1

OK blueprint for a mech that has this issue https://spaceengineers.mod.io/auto-drill-mech2 instructions in singleplayer retail or Beta on xbox one x, cockpit at the top has control panel right hand side , press the squat button to put mech into squat position. copy mech and paste it, it will explode, in squat position also leave game, when reloaded the mech will explode. here is a vid of it happening https://studio.youtube.com/video/fBHwPopV9HE/edit

Paul Thompson

icon-envelope-tick-green-avg-v1 Virus-free. www.avg.com

On Tue, Mar 30, 2021 at 9:46 AM <support@keenswh.com> wrote:

photo
1

Hello Engineer,

we have tried this blueprint. Unfortunately we're seeing it explode every time we try the Squat button. Would it be possible to share a blueprint with a similar issue, but smaller? We have tried creating one, but the described bug isn't happening on our side.

Thank you.

Kind regards,

Keen Software House: QA Department

photo
1

"Whilst I would love to oblige, my time is sadly limited, so I will be unable to test it. I'm happy to help with further information if your QA department needs it"

Paul Thompson

icon-envelope-tick-green-avg-v1 Virus-free. www.avg.com

On Wed, Mar 31, 2021 at 10:56 AM <support@keenswh.com> wrote:

photo
1

Hello Engineer,


Since there are no new comments in this topic and we are still not able to reproduce it, we are closing this thread as outdated.


In case anyone is encountering the same or similar bug, which is not already posted in a different thread, please feel free to create a new thread with all relevant information.


Thank you.


Kind Regards

Keen Software House: QA Department