This object is in archive! 

Unable to Charge Ship Battery With Connector.

Brandon shared this bug 22 months ago
Won't Fix

Hey so I’m having a hard time figuring out what I’m missing. My ship and base connector are green with both allowing trade. My batteries are set to recharge but my batteries aren’t actually charging. I’ve tried leaving the ship off and running and sitting in the cockpit for both attempts. I’ve also reset both connectors then the entire grid using the control seat. I built a battery right next to the base connector and tried connecting it to the connector and it was able to recharge off the grid and I set it to discharge but it wasn’t able to recharge the battery in the ship. For my last ditch effort I’ve also tried rebuilding both connectors and my whole ship. For some reason it’s still not allowing it to connect to the base grid. I have 4 wind turbines 3 solar panels with 3 storage batteries for my base so I should have enough power to charge it. I don’t know if it matters but I’m playing on the Xbox One.

Replies (1)


Hello, Brandon,

thanks for coming to us and letting us know about your concern. However, while this issue might be - at some environment, grid build or other variables - observed on PC as well, I would definitely need your save file. And since you are playing on Xbox, as you mentioned, I would not be able to run it.

Please contact our Xbox support on this forum.

Will close this one, as on PC I have no way how to help you. Sorry. Hope you understand.

Kind Regards

Keen Software House

Replies have been locked on this page!