Player in cockpit preventing other players from controlling grids in MP dedicated servers.

Ryunoske shared this bug 19 months ago
Reported – Awaiting fix

What happens is: a player gets in cockpit and flies/rolls away from the base, on which there are other players. These other players can't controll ANY grid when they get in cockpits/controll seats UNTILL that one player exits cockpit. Then he can enter enter it again without any more problems. By controll I mean thrust and gyro controll. Using connectors, breaks and terminal blocks remains possible.

This happens often in a server that I am playing on, and has been happening for a few years now.

Best Answer
photo

Hello, Ryunoske,

thanks for sharing this issue with us. It was successfully reproduced and put into our internal system.

Kind Regards

Keen Software House: QA Department

Replies (5)

photo
3

Is anyone seeing this?

photo
3

Hello, Ryunoske,

thanks for sharing this issue with us. It was successfully reproduced and put into our internal system.

Kind Regards

Keen Software House: QA Department

photo
2

Thanks for reproducing this issue. My friends and I are eagerly anticipating the fix as it has become quite troublesome in our games.

photo
3

Here are my symptons. This is a multi-player game.. not dedicated server, but appears to be identical symptoms.

A friend and I had the issue repeatedly where we could not control our ships that were both docked to a stationary grid. Sometimes leaving the cockpit and getting back in would fix it, sometimes If I (host) whent into his ship, I could drive it, and then he could. We would often see message on screen "another ship has taken control" messages. So we are theorizing that it could be related to docked ships taking control of the grids and not releasing them. But there is no rubber banding for us, beause we cannot get ANY control of the grid to even attempt to fly away from a connector. I will see if there is another similar issue on another thread or create a new one.ffor our sysmptoms.

Facts:

  • Happens when docked to station grid
  • Happens when I am hosting a game
  • Happens somewhat randomly, cannot detect a pattern, but happens farily often.
  • Happens with all clients (host and two other players)
  • One fix is if client cannot control a ship, is host getting in, controlling and then getting out.
  • Sometimes affects Host as well. Fix may also be client getting in and controlling and then getting out, but need to verify.
  • Hotbar mapped controls still work. WASD does not work
  • Sometimes disconnecting from a grid and using a remote control block and auto-pilot script can 'free' the controls again, but it happned only once for me, so not sure it is causal.
  • Often see messages while docked to static grid in ships (Another grid has taken control) - or something to that effect.
  • Tried turning off "main cockpit" off on all attached control seats or cockpits with no aparent change.

photo
1

Fixed in Heavy Industry it seems?

"Fixed a loss of control for ships being unlocked by a client"

I can't reproduce anymore

photo
1

We will find out this weekend when we play. As every weekend we play, we have had the bug happen multiple times. Got so bad its habit now for us all to get in a ship, unlock connector, hope out of ship and hop right back in. So that it clears the broken issue.

Hopefully it is indeed fixed. Its been a 2+ year bug/annoyance.

photo
Leave a Comment
 
Attach a file