High Thread CPU Usage

Tyler Moss shared this bug 3 months ago
Won't Fix

Getting some crazy high thread cpu usage when everything else is fine, no matter what settings i change for my machine or the server, it persists. Constantly at or above 120% even with a ryzen 9 3900x running on Precision Boost and the cores are handling it fine.

Comments (2)

photo
1

Hello, Tyler!

Sorry to hear you're experiencing this issue. What are you doing when this happens? Are you only finding this online or offline too? Are you in an intensive world or in a fresh one? Are you using any mods at all? Could I please ask for a copy of your log from when you experience this? Is this something that has been happening a while or from one of the recent updates? Any further information would be great.

You can access your log files by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers.

Kind Regards

Laura, QA Department

photo
1

Nothing I do seems to trigger it, have tried fresh world, server migration, all mods off, taking away pistons and intensive blocks, and this has happened as long as I've been playing but only recently to the extent of sometimes causing heavy frame lag. I can get you a log when I get home later

photo
1

I can't find the logs in that folder

photo
1

Hello, Tyler!

They should be in that folder and be dated/timed from your latest play session as SpaceEngineers_ (with quite a few numbers) as text documents. Please let me know how you get on :)

Kind Regards

Laura, QA Department

photo
1

/499669b03fc5c7704c2070784eb30945


This is what my resource monitor shows while thread CPU is at 160%, so I'm lost.

photo
1

Hello, Tyler!

Earlier you mentioned that this issue still happens without mods, I see this particular log does include mods would you be able to test what you're running with these 5 disabled? Is this only happening in a dedicated server setting or will it happen if you play offline too? Also, will this happen if you join an official server for example?

Kind Regards

Laura, QA Department

photo
photo
2

Hello, Engineer!

Because there is no new comment from you, and we are unable to reproduce the issue on our own, I will close this thread now as outdated.

If you or any other player will experience this issue again, please make a new thread and provide all needed info there.

Thank you for understanding.

Kind Regards

Keen Software House: QA Department