game often hangs for +1 minute (high end rig, unmodded & modded)

Jordy Ulb shared this bug 2 years ago
Outdated

Hello.


Since a few days i have been having problems with the game hanging (application not reacting) for over a minute multiple times during a play session it can happen at any point in the menu, in inventory screen or whilst mining,... .


Steps I've taken:

Unsubscribed from all mods

Deleted appdata/roaming Space engineers

Reinstalled the game fresh on 2 different drives.

tried different graphics pre sets (Low,Medium,High)


Keeps happening to me on every new survival world i create (only tested earth)

with the easy start earth and the star system start.


system specs :

Ryzen 9 3950X (not overclocked)

Aorus X570 Ultra

32GB 3600Mhz RAM

Aorus RTX2080TI ( yes graphics drivers are up to date)

Replies (5)

photo
1

Same issue, hangs then crashes in modded and unmodded. I also have a high end rig. Done the same thing as above. For me I believe it has something to do with the frostbite update as when I play on older versions I have no issues.

photo
1

I have the same problem, even though the freezes last less than a full minute (say around 20-30s)

After the freeze the game continues as if nothing happened; it freezes quite often, unfortunately, but no crashes.

I've seen similar reports from other people on AMD Ryzen CPUs, for what it's worth.


My PC:

AMD Ryzen 3900x (motherboard chipset X570)

32GB RAM

RTX 2070 super, latest WHQL nvidia drivers

Latest version of Space Engineers (recently bought the game, so it's the only version I've ever installed of it)

No mods, no overclocking

photo
1

Same problem with an AMD ryzen 3900X processor, GTX 1080 and 16GB of ram.

All my drivers are up to date... I even tried to reinstall the game entirely but it didn't change anything.

No mods, no overclocking

photo
1

RyuSansoku ● 4 days ago

After much "tinkering" I have found that the game is pretty much stable and full function after doing what you mentioned with a bit of a difference, I only copied (Overwrite/Replace) the "VRage.Library.dll" from the Mod SD "Bin64_Profile" folder to the Space Engineers "Bin64" folder.


Played for 12hrs (I missed it so much) no "thread allocation issues" or "not responding errors/crashes"

All mod dialogues and plugin extras working as intended.


Tested and working on:

Ryzen 9 3950x 12hr (Me) - Single Player, Frostbite, Dedicated MP Server With 178 mods

FX-8320 6hr (Other) - Dedicated MP Server With 178 mods

FX-8350 1.5hr (Other) - Dedicated MP Server With 178 mods


Hope this help anyone interested, Clang away happily fellow Space Engineers.


This worked for me

photo
photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

Hi,

As an unnofficial workaround, some people have reported success with replacing a dll in the space engineers folder with one from the mod SDK, as detailed here:

https://steamcommunity.com/app/244850/discussions/0/2259060348500655858/

"Go to your library on steam and find the tools tab. Find space engineers - mod sdk and install it. It's a free dev tool that Keen released to everyone. Open its folder and then open Bin64_Profile. Copy VRage.Library.dll. Now open your space enineers folder and paste this .dll in its Bin64 folder. Click yes to replace the existing one.


The only issue seems to be periodic stutter, but I haven't noticed it on my R9 3900X and GTX 1080ti.


Edit: Do be aware that you'll need to replace this .dll file every time the game is updated (or at least each major update)."

Leave a Comment
 
Attach a file