Critical GPU crashes

Bob Jones shared this bug 3 years ago
Outdated

So typically this game crashes every few hours on me, either with a "GPU crashed" error, or with this error which I can get to easily repeat by opening Waterfox while in game. I am running 64 bit Windows 10, my GPU is a AMD 580 with 8gb of ram, and Space Engineers is never using more than 3gb of my 12gb of ram. I also verified the game is running the 64 bit Space Engineers by opening task manager and seeing where SpaceEngineers is running from (bin64).


I tried to recreate this issue however when I started up a world and immediately opened Waterfox my GPU crashed completely, as in monitors weren't responding at all. This has happened with my GPU Driver on version 18.7.1 and 18.6.1. I've also had the game completely crash my computer to the point of it rebooting, but that is rare, and I cant reliably recreate that.

I thought this might have been a power supply issue or overheating issue so I ran Heaven and Cinebench at the same time for about half an hour and my computer was (relatively) fine. I also created a new world in empty space with no mods and and wasn't able to get the game to crash, but I did an easy save earth world and as soon as i started Waterfox the GPU crashed completely.

I've also verified the integrity of the files in SpaceEngineers, and I've also ran the game at minimal settings with no mods and it still crashes.


Attached is the log with the error that I am running in 32bit, the Space Engineers logfile and finally a relevant event from EventViewer.

Replies (8)

photo
1

Verified RAM was working through memtest, also followed various guides to improving windows 10 and ram use including disabling the "maximum memory" setting during boot, ensuring paging files were disabled, and also switching the ram around on the motherboard.

My computer seems to be very reluctant to use a lot of memory, I was about to get Waterfox to use up to about 4gb of ram through opening a bunch of Youtube videos, and I was able to push it to about 6 through memory allocation software.

photo
1

Happen to have a SpaceEngineers.log for one of these occurances?

photo
1

Freshly crashed for your convenience. If you need more crashes I can totally do that for ya.


Also task manager is useless for reporting ram usage apparently, Process Hacker showed me recently using up to 7gb, though programs like discord crashed as well.

photo
1

2018-07-29 03:35:35.357 - Thread: 17 -> Exception in render!


Aftermath: Main(|FAIL_NotInitialized|Unknown|NotStarted) Deferred()

Exception: SharpDX.SharpDXException: HRESULT: [0x887A0005], Module: [SharpDX.DXGI], ApiCode: [DXGI_ERROR_DEVICE_REMOVED/DeviceRemoved], Message: The GPU device instance has been suspended. Use GetDeviceRemovedReason to determine the appropriate action.


at SharpDX.Result.CheckError()

at SharpDX.DXGI.SwapChain.Present(Int32 syncInterval, PresentFlags flags)

at VRageRender.MyRender11.Present()

at VRageRender.ExternalApp.MyRenderThread.RenderFrame(Boolean async)

at VRageRender.ExternalApp.MyRenderThread.RenderCallback(Boolean async)

Statistics: Resources:

Resources count

Array textures: 12

DepthStencils: 2

Custom textures: 2

Blend states: 20

Depth stencil states: 32

Rasterizer states: 11

Sampler states: 10

Deferred RCs: 46


Hardware Buffers

Srv TotalBuffers: 3

Srv TotalBytes: 2,027,520

Srv TotalBuffersPeak: 3

Srv TotalBytesPeak: 2,027,520

Uav TotalBuffers: 1

Uav TotalBytes: 1,638,400

Uav TotalBuffersPeak: 1

Uav TotalBytesPeak: 1,638,400

SrvUav TotalBuffers: 6

SrvUav TotalBytes: 62,798,660

SrvUav TotalBuffersPeak: 6

SrvUav TotalBytesPeak: 62,798,660

Indirect TotalBuffers: 2

Indirect TotalBytes: 36

Indirect TotalBuffersPeak: 2

Indirect TotalBytesPeak: 36

Read TotalBuffers: 3

Read TotalBytes: 48

Read TotalBuffersPeak: 3

Read TotalBytesPeak: 48

Index TotalBuffers: 1,718

Index TotalBytes: 30,585,894

Index TotalBuffersPeak: 2,121

Index TotalBytesPeak: 35,861,988

Vertex TotalBuffers: 3,813

Vertex TotalBytes: 133,832,888

Vertex TotalBuffersPeak: 4,619

Vertex TotalBytesPeak: 150,903,080

Constant TotalBuffers: 58

Constant TotalBytes: 75,056

Constant TotalBuffersPeak: 58

Constant TotalBytesPeak: 75,056

Total TotalBuffers: 5,604

Total TotalBytes: 230,958,502

Total TotalBuffersPeak: 0

Total TotalBytesPeak: 0

FoliagePool # used: 26

FoliagePool bytes used: 6,836,224

FoliagePool # allocated: 52

FoliagePool bytes allocated: 13,672,448


Mesh buffers

MyMeshBufferPool # used: 2,068

MyMeshBufferPool bytes used: 47,564,664

MyMeshBufferPool # allocated: 3,277

MyMeshBufferPool bytes allocated: 79,525,064


File Textures

Total: 1,587

Loaded: 1,334

Memory KB: 882,120

Total (peak): 1,587

Loaded (peak): 1,334

Memory (peak) KB: 882,120


Loaded File Textures: COLOR_METAL

Compressed Count: 179

Compressed Memory KB: 172,615


Loaded File Textures: NORMALMAP_GLOSS

Compressed Count: 160

Compressed Memory KB: 141,429


Loaded File Textures: EXTENSIONS

Compressed Count: 145

Compressed Memory KB: 105,461


Loaded File Textures: ALPHAMASK

Compressed Count: 23

Compressed Memory KB: 22,144

NonCompressed Count: 4

NonCompressed Memory KB: 6,826


Loaded File Textures: GUI

Compressed Count: 397

Compressed Memory KB: 27,660

NonCompressed Count: 402

NonCompressed Memory KB: 50,174


Loaded File Textures: CUBEMAP

Compressed Count: 2

Compressed Memory KB: 133,120


Loaded File Textures: SYSTEM


Loaded File Textures: CUSTOM

NonCompressed Count: 20

NonCompressed Memory KB: 47,924


Loaded File Textures: GPUPARTICLES

Compressed Count: 2

Compressed Memory KB: 174,762


Texture Arrays

Total: 22

Memory KB: 467,968

Total (peak): 22

Memory (peak) KB: 467,968


RW Textures

Total: 34

Memory KB: 429,155

Total (peak): 38

Memory (peak) KB: 435,299


Generated Textures

Total: 45

Memory KB: 86,016

Total (peak): 45

Memory (peak) KB: 86,016

photo
1

Related link: How to fix error 0x887a0005


Looks like your vid card isn't keeping up with your settings.

photo
2

Hm, well tomorrow I'll do more testing, I know it's not power supply or thermals issue, if it was I'm sure half an hour of benchmarks would have got them to crash. Thanks for the direction, should figure it out soon.

photo
1

Yup its my GPU apparently, how is it not keeping up though? its got 8gb of memory, makes no sense that it would immediately die when something else is opened up. Also it crashes Discord after a while even on 1080p settings...

Finally for your viewing pleasure, bare minimal settings, keep in mind this was on a 28in 4k monitor, so zoom in to get the true experience.

photo
1

Just a thought but do you have "page file" aka "virtual memory" enabled, if so then is it on system managed size or something else?

photo
photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

Good Morning,


Thank you very much for considering this issue, though I think its been solved.


I recently (this morning) did a clean install of the latest AMD drivers for my GPU (18.12.3) and ensured Windows was up to date, (version 1809) and tried to get the issues to occur again. I ran around in the default scenario, crashed the red ship into the station, etc and didn't get it to crash, even with discord and waterfox (would previously instantly kill the system) running.


Also tried easy start earth and still couldn't get the system to crash, so I think we're good to go here, thanks for all the help!

photo
1

Unfortunately i have the same issue. After two hours the system shuts down discord, and will not let it re-open as long as the session of space engineers is still running. after an additional hour I get random black screen flashes. After an additional 30-45 minutes the GPU just shuts down, no warning and no error log. The GPU is running the latest drivers and is quite literally brand new. also running the most up to date version of windows.

photo
1

I have the same issue. I am running a 980Ti and up untill I updated the official Nvidia drivers about a week ago, the game was running just fine. Right now the game crashes either immediately when booting up or, when i rarely get to actually reach the menu.. it crashes when loading in a game. The prompt says the driver crashed due to overheating, though I have no problems running any other game and everything seems to be in working order .

photo
Leave a Comment
 
Attach a file