Constant crashing every five minutes.

Shawn G shared this bug 46 days ago
Need More Information

So I'd like to start off saying I've done literally everything, and I'm not looking forward to a copy paste response.


Ever since I've purchased sparks of the future, the game crashes after 10 minutes. The log NORMALLY ends with "2020-09-01 21:45:26.745 - Thread: 1 -> GC Memory: 1688.029 / 1688.029 MB". I even tried uninstalling and reinstalling, verifying cache, even completely wiping everything that has to do with the game from my system and installing it on three different drives, with one of them having only the game installed, to no avail.

Apparently the "GC" is something to do with "Garbage Cleanup", but I've had crashes where that's not the last line. I noticed that when the game crashes, my GPU's activity just plummets. My GPU rarely gets close to 70C.


Again, this has happened only after purchasing and installing sparks of the future. I tried purchasing all other DLC's thinking it may have been a compatibility issue, but it didn't fix anything. If a dev sees this and wants the entire log, message me and I'll send it to you because I'm not flooding this with the log.


And yes, I've tried different graphics drivers

With/Without mods

Experimental on/off

Clean world, empty world, every planet,

lowest to highest possible graphics settings.

Installing the game on multiple drives.

Disabling all anti-virus software(including windows defender)

Firewall on/off

Online/Offline play


Anyways, my system specs are as follows.

RTX 2080 with 8BG VRam.

Ryzen 5 2600X

Ran the game on a samsung 970 evo pro, a kingston ssd and my hard drive to no avail.

MSI X470 Gaming Plus

16GB DDR4 Ram running 3000mhz.


Appreciate any help I can get.

Comments (2)

photo
1

Hello, Engineer!


Thank you for your information. Please attach here your Space Engineers log file. You can access your log files by typing %appdata% into your windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers\SpaceEngineers.log.


Which operating system do you use? Is it updated?

Do you have the latest version of graphic drivers?


In addition you have already tried, give it a try to:

  • Update your graphic drivers
  • Install VC Redist 2017 (in case you don't have it)
  • Reinstall the game
  • Delete SpaceEngineers.cfg
  • Start the game


Thank you. Any additional information will be greatly appreciated!


Kind Regards

Keen Software House: QA Department

photo
1

I've done everything you've suggested more than twice.

Windows 10, fully updated.


I've attached the latest two logs, as well as the Direct X logs in case something in there could tell you anything.

photo
1

I'll add this, I managed to get it working for about an hour and then it crashed, and now it won't run longer than 3 - 5 minutes.

Here's my latest two crash logs.


I'd also like to add that this game makes my GPU run like it's Usian Bolt, and it's a 2080, so maybe the usage has something to do with it?

photo
1

Not sure if you even care anymore, but I've done some digging of my own. The crash is coming from .NET Runtime.

exception code c0000005, exception address 000000018002E450.

Faulting application name: SpaceEngineers.exe, version: 1.0.0.0, time stamp: 0xfd592b02

Faulting module name: RTSSHooks64.dll_unloaded, version: 0.0.0.0, time stamp: 0x5d76621d

Exception code: 0xc0000005

Fault offset: 0x000000000002e450

Faulting process id: 0x2ae8

Faulting application start time: 0x01d696f171170ed9

Faulting application path: B:\SteamLibrary\steamapps\common\SpaceEngineers\Bin64\SpaceEngineers.exe

Faulting module path: RTSSHooks64.dll

photo
photo
1

Feels like this issue is just being ignored.