Big solar power problem - Rotors stop working when the user is far away

Usernamenotshown shared this bug 6 months ago
Won't Fix

I'm playing on the official servers, and I can't leave my base because the solar panels will stop moving with the sun and the power supply will collapse. Please fix Keen

Replies (3)

photo
2

Hello, Usernamenotshown,

thanks for letting us know.

However, I do not fully understand the issue that you are talking about.

As you said you are playing on official server, I take it there are no mods included, right?

Do you mean just normal solar panels on normal rotor? Something like on the image? If yes, there is no issue on my side.

Are you using the rotor like... rotating all the time from rotor settings in Control panel? Or are you using some script injected into programmable block? If it's script, you would need to contact the script creator and let him know. Most likely this won't be issue on our side.

Also, how far do you exactly go, when you observe that the solar panels (and rotor) stop working? And how do you know it's not when you are not there and not seeing it?

If you blueprint the base and paste the blueprint into other game (single player or Lobby mode) is the issue still the same there as well? Are you playing on any (what?) planet, or do you have the base located in space?

Can you share me the blueprint (or save, if it's broken in SP/Lobby as well), so I can try it on my side with your exact build and in the same environemnt? Any other information that you can provide would help me.

For save:

You can access your save files by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers\Saves. There should be a folder with your SteamID and your saves.

Please zip the file and attach it here. If you are having difficulty attaching files you can optionally use Google Drive. When sharing a google drive link please make sure it is set to be downloadable by anyone with the link.

For blueprint:

You can access your blueprints files by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers\Blueprints. Select the correct folder where your blueprint is saved (local or cloud), zip the file and attach it here.

Thanks in advance.

Kind Regards

Keen Software House: QA Department

photo
1

Hello, thank you for writing back.

Yes, I'm on the official servers, so no mods and no scripts.

Yes, it's like your image, but also it has a small grid solar tracking device that triggers a speed increase and speed decrease sometimes to keep the large grid array pointed at the sun (It's a solar panel positioned perpendicularly to the main panels, and it rotates a small arm that is detected by a sensor on the big grid. (Nevermind this part, I disabled it and went for pure rotor rotation for today's tests.)

I have observed it when I have visited the nearby planet (1600 km), either by jumping or suiciding and spawning a planetary spawn pod. I have marked the coordinates in the sky at 10 light years on the solar plane to make them into perfect angular measurements. I made 12 such points (like a clock). So I waited until the sun was at point 10, aligned the solar panels properly, and suicided to the nearby planet (Titan). There, I waited 10 minutes (one division of this sky clock thing), until the sun reached point 11. I suicided again, after deleting the spawn pod, and respawned in my ship. Looking at the sky, the sun was at the 11th point, while the solar array was still pointed at the 10th point, this means it stopped moving the moment I went away.

It's a space station.

As you said, I have tested this too in single player and there it seems to work properly. I left it in Earthlike's orbit and respawned in Mars. After ten minutes I can say with the same method that it worked properly. (Also because it was still pointing at the sun) The offline world is a normal star system


Here are the coordinates for the angles on the sky:


GPS:Solar plane 12:94646401765632000:0:0:#FFFFFFFF:
GPS:Solar plane 1:81966188305825700:0:-47323200882816000:#FFFFFFFF:
GPS:Solar plane 2:47323200882816000:0:-81966188305825600:#FFFFFFFF:
GPS:Solar plane 3:0:0:-94646401765632000:#FFFFFFFF:
GPS:Solar plane 4:-47323200882816000:0:-81966188305825700:#FFFFFFFF:
GPS:Solar plane 5:-81966188305825700:0:-47323200882816000:#FFFFFFFF:
GPS:Solar plane 6:-94646401765632000:0:0:#FFFFFFFF:
GPS:Solar plane 7:-81966188305825700:0:-47323200882816000:#FFFFFFFF:
GPS:Solar plane 8:-47323200882816000:0:-81966188305825600:#FFFFFFFF:
GPS:Solar plane 9:0:0:94646401765632000:#FFFFFFFF:
GPS:Solar plane 10:-47323200882816000:0:-81966188305825600:#FFFFFFFF:
GPS:Solar plane 11:-81966188305825700:0:-47323200882816000:#FFFFFFFF:
photo
1

Hello, any news on this?

photo
photo
2

Hello, Engineer!

Thanks for providing more information but I'm still not able to reproduce this said issue.

I was trying it in all possible situations - single player, Lobby mode and on dedicated server (same as official servers). I was waiting quite far from the array (3000 to 5000+ km), waiting logged off from the server, killing myself etc.

I took a note of the rotor position (the value displayed in the Control panel) and when I came back, the value was different each time, suggesting that the rotor was working all the time; when I died, when I was far away, when completely logged off.

Here are some of mine values - 73° when I started, moved away, waited (10 mins, like you), came back and the rotor value was changed properly to 110°. In all other tries, it went in the same manner (from 315°to 353°, from 355° it rolled over and the value was 30° upon my returned... and so on). See the image.

Can you confirm, that in your case, the value in rotor's Control panel in the same? That would suggest that it is not working when you are far away/logged off.

I know that providing video for this issue might be quite hard, but if you can think of something, how to show it to me visually, it would be great! If video would prove not doable, can you please at least share me a screenshot, so I know how exactly you have the array oriented towards the sun, and how the GPS system (the clock) you are mentioning is looking in the game?

Thanks in advance.

Kind Regards

Keen Software House: QA Department

photo
1

I will try to make a video

photo
1

Hello, I made the video. Sorry for the quality, my computer is not powerful enough. I was also having trouble uploading the files here, so I made a Mega folder. There is the video and a diagram that I hope explains it a bit.

First I look at the array, it's aligned with the sun at about 11,5. The rotor is at 285º. All good.

I take the jumper and jump to Titan orbit. I look at the sun. As expected, the sun is at 11,5. I wait for ten twenty minutes, until the sun reaches point 1. For this movement of the sun there should be the same movement of the rotor (1/120=0,008333 rpm). I jump back to the base, the sun is at 1 here too. I check the rotor, and it's not pointing at the sun. Looking closer, it did move, but just a bit. It moved from about 11,5 to about 11,75, so maybe 7 degrees. The sun, now at Point 1, has moved maybe 45 degrees. I was a partly wrong, the rotor does not stop working, but it does not seem to turn at the set rate when far away. When close by it follows the sun properly

The thing about the points is that we believe that the sun moves in a fixed path, and that it is anchored on the player's head, so if the player moves, the sun moves with him. This path is divided in 12 points at the same distance. To absorb the error of moving around, the points are placed far away, at 10 lightyears. This way, they seem very exact to the player from many different points.

I wait for your response. If all this is not enough, please come to EU1(SSS - Solar System Society, grid name = Solar module R2A, R2B, etc.) to see it in person

Files: https://mega.nz/folder/YdpSWISL#2EnhWve_2N3FpCguqbolgQ

photo
2

I'm experiencing the same problem. I've got a rotor set to match the sun's rotation. It will track the sun for hours if I stay at my base. But as soon as I get in my ship and fly over to the nearest asteroid to do some mining for 15 minutes, the rotor is out of sync.

Additionally, when I return to my base and get close (maybe within 150-200m), the game plays a "power up" sound as if I had pressed the Y key.

The game is definitely turning off the rotors when no players are near them.

Edit: I'm on Keen NA#2 pub server.

photo
1

Hello Engineers,


Thanks for the video and your feedback.


Let's simplify. There are 2 'problems' you are reporting.


1. Rotors are not working when player is 'away'


I tried all described scenarios (and some more) on vanilla servers with default settings. I was not able to reproduce the issue. I started a new server for each scenario and it did not happen once.


It would help tremendously if you could describe how to reproduce the issue in simple steps.


2. Rotors are working, but not at set rate when 'far away'


For me it is the same as 1. If I flew away with jetpack, flew away with ship, set up base x000km away from base and suicided, died and respawned on another planet, ... ... ... when I got back, the rotor was rotated properly and as expected.


Are you sure the station is static and not moving? It seems that your station is anchored to asteroid, but it's really hard to recognize the exact setup and what is going on, since the quality of provided video is not the best.


Note1. Rotors are not in sync with sun when velocity is set to 0,0083 rpm


Simple answer - rounding. As 0,0083*120 = 0,996, there will always be a little offset with this design. You can always get inspired on workshop/YT, where people designed maintenanceless Solar tracking systems (you can choose Vannila no script, modded, scripted, ...), that might do what you are trying to achieve.


Note2. If you have only Solar panels providing power on your grid, are you sure they

  • provide enough energy output for required energy costs
  • sun was always powering Solar panels (e.g. asteroid/planet could shade your grid, hence the offset when returning)


If you can think of anything else that might help, please let us know.


Kind Regards


Keen Software House: QA Department

photo
photo
1

Hello, Engineers!

Because there is no new comment from you, and we are unable to reproduce the issue on our own, I will close this thread now as outdated.

If you or any other player will experience this issue again, please make a new thread and provide all needed info there.

Thank you for understanding.

Kind Regards

Keen Software House: QA Department

Leave a Comment
 
Attach a file