1.196 Asteroid desync - screenshots

fastndead shared this bug 11 months ago
Duplicate

Playing with friends


One person can see asteroid

For other it is invisible

F5 doesn't solve the issue

Screenshots were taken on UK#1 server

Comments (6)

photo
1

Yeah I am having a similar bug on a keen server as well. I almost crashed into it actually.

photo
1

Also we noticed that asteroids despawning (when touched?)


At the moment we have “Single serving asteroids” as far as I can see.

1) I was mining uranium

2) didn’t finish it, should be going outdoors with friends. Returned drill to base.

3) when I’m back - asteroid was missing.

4) wtf?

photo
1

Yep, so this is the correct place to complain about this issue.

Seems that SaveFile shrinker is acting up.

As far as I have experienced:

40-50 minutes, asteroids are fine

at 2 hours, they will MOST LIKLEY be deleted


the behavior is not consistent


some asteroids get deleted and you never find them

some get replaced by fresh copies according to the world seed, carbon copies of their original selves

usually it's the uranium ones that never respawn.

not sure which if any is the intended behavior of this function.


1 is definitely a bug (or both)


either way, they are terrible for gameplay

photo
1

Hello, Engineers!


Thank you for contacting us. Can you please provide us with more information?

  1. Besides Keen servers, do you experience this issue also on your local dedicated servers?
  2. Do the asteroids disappear after some time (cca 2 hours) as November Delta Charlie wrote?

Any additional information will be greatly appreciated.


Kind Regards

Keen Software House: QA Department

photo
1

November Delta Charlie's account seems to be what I experience. The dedicated server I play on has an asteriod belt in a fixed position I believe. After the last patch, I attempted to go mine known ore deposits as I've done for months. Many were not there. I found new ore deposits, marked them, returned a day later, they were gone too. Seems to be getting worse.

photo
1

Had this issue two days ago, but without even mining. For the me asteroids just don't load in until I crash into them or just seconds before, whereas my friend who's hosting the server can actually see all the asteroids

photo
photo
1

Hello, Engineers!


We have reproduced this issue and we will address it as soon as possible.

Thank you for your patience.

Kind Regards

Keen Software House: QA Department