This object is in archive! 

Random encounter max pcu.

Jaden Gerome Roland Gagnon shared this bug 7 months ago
Need More Information

I’m playing multiplayer with my friends on my own world and all my encounters say pcu limit reached. I tried restarting the world but it didn’t work.

Replies (1)


Hello Engineer!

Have you tried increasing PCU in the world's advanced settings? You can edit settings for saved worlds too. If possible, could you upload a save to and share a link in this thread so we could try reproducing the issue you're describing?

Thank you!

Kind regards,

Keen Software House: QA Department

Leave a Comment
Attach a file