Group Update not Saving (Xbox)

John Dawson shared this bug 4 months ago
Reported – Awaiting fix

So I've got another grouping-related bug that I have had since release but not realized why until recently, this on Xbox.

So this bug involves like in the video connected when a group is created with unintentional parts in this case 2 sorters that I had previously selected to hide from the list but were still selected when i created a Hydrogen Tanks group causing the group to be mixed so functions weren't available like setting tanks to stockpile et this as per normal.

the bug is when editing an existing group and removing parts from it and then saving it, it will register until the vehicle is, as shown copied or as I had it before, if it was saved and brought out the group would revert to the original saved list including the blocks previously removed.

one way to resolve this in-game is to delete the group and make a new one but with larger ships and extensive lists, it can be time-consuming, and with one of my previous bugs being the Group Selection Bug (Xbox)


More info: I play on an Xbox One X and currently own all DLC but as previously stated I had this really early on in its cycle so not sure DLCs could have caused this.

Thanks for taking the time to read this hope to hear from you guys soon.

Replies (1)

photo
1

Hello Engineer,


We've been unable to reproduce the bug you've described. Could you please tell us if it's happening on Single Player or in Multiplayer for you? Could you check if it can be reproduced on a Single Player world without mods on your side?

Thank you.


Kind regards,


Keen Software House: QA Department

photo
1

Okay, so I found the main issue, which is that as the video had shown the 2 sorters are on a subgrid. through testing on various size grids and different blocks and a non-modded game, I was able to replicate it. Basically having the blocks all on 1 grid doesn't trigger it just if an item is on a subgrid it can cause the bug to occur

video attached shows it on a large grid with a battery instead of sorters

photo
1

Hello Engineer,


Thank you for this additional information, with it we've been able to reproduce the issue. It's been reported to our internal system. We will update this thread when we have more information.


Thank you.


Kind regards,


Keen Software House: QA Department

photo
1

that's amazing. hopefully, it doesn't take too long to get fixed but am happy to wait thanks

photo
Leave a Comment
 
Attach a file