Space Engineers Beta - Several Bugs

SiHO colus shared this bug 3 months ago
Need More Information

i report 3 Bugs that appears in the Beta Version of Space Engineers for Xbox Consoles.


1st Bug: Timer Block Page 2 to 9 wont work except Page 1. this bug makes almost all my Builds Unplayable.


2nd Bug: even after 2 Years i reported a Bug that my Ships sinking trough Stationary, Large and Small Grid Platforms aswell on Voxel like Planets. and even i reported that with a Map that contains one of my Ships that shows sinking trough voxel, my Bug report got the ''Wont Fix'' tag. for real, i dont really understand what your Goddamn problem is, keen! are you guys too lazy to fix it or what is your problem?! My Ships are sinking trough other thinks or Voxels! with damage on they destroy itself or damage off thy keep yeeting itself into the Space. THIS IS UNACCEPTABLE! the only Thing that prevent my Ships from Sinking through voxels are Subgrids. like Wheels from the Wheel Suspension Blocks, or magnet plates/magnets/Landing gears build on Hinge-, Rotor- or Pistonheads as Subgrid. i dont know why you Devs dont care of that bug but its hella annoying! my patience after 2 years comes to an end, so fix that shit! - and YES: it started already before the Xbox version got modding support, so it is NOT caused by Mods, not caused by Experimental mode, NOTHING. it is just there, sucks my Ships into the landing Platforms/Planet surfaces, the CLANG Kicks in and Shredding my 200M Large ship into Pieces or yeets them Back into the Space. so PLEASE: FIX IT!

3rd Bug: on the menu, the World lsit is kinda Buggy. for example, if you scroll down to the 3rd top world, and open its settings, it could happen that the game somehow just open the 1rst world or the 2nd world settings. when i wanted to play a world where i building Trains, and go to the settings to check/put new mods for the world, it opens the world settings above even if the Game CLEARLY shows that i scrolled to the World with the trains. so please fix that aswell.

4th Bug: when you enter a Seat and then enter a Custem Turret Controller to control it, and Use it for a while, and then exit the custom turret controller and switch to first person, your character is slightly glitched a bit forward, so your character body sits INTO the Panel table of the Seat.


5th Bug: the Engineer Armor parts, aswell the Weapons/Tools skins still keeps reset. i dont know when or even how this occur but the bug still exists, its not Patched anymore (because one of your Hotfixes mentioned that this bug would been fixed) - this Appears in both versions of Space Engineers, the Beta and Retail version on Xbox.

6th Bug: Missile launcher Snaps back when firing, again both version of SE for Xbox.

Replies (5)

photo
1

Hello Engineer,

We're aware of some of the issues you've described, they either have been already fixed and available on Release version or will be fixed in the next major update.

Could you be a little more specific about 5th and 6th issues?

Are your skins resetting after a specific action, like reconnect or character death?

What do you mean, snaps back? Could you record and share a video?

Thank you.

Kind Regards

Keen Software House: QA Department

photo
1

5th Issue: i dont really know. I believe it resets when i completely Turn off my console (i mean when its really Turned off, like as if the console is on normal Start mode, not instant on) or when i Play a Different Game. It might be also Pissible that the Skins and Armor parts also resets, when i delete the Private Save under the game Settings on Xbox. I have to do this Really often, because im Playing the Game much more with Mods, but when i had too many Different Mods, for Example Have too much Mods loaded into one World, (2,30GB) the Loading screen standing forever and Wont Open any World, even those who have just a Few or none Mods Active. The Only Solution to fux that issue (or Bug) is deleting the 4GB file. But deleting this File causes many Changes in the Game, for example the Settings: i have to turn off and then Back on the Experimental Mode, despite it was actually Already on and i also Have to agree the Mod.io agreements again. So overall: when the Game stops running because it is Overloaded with Mods in that 4GB Private File, and you delete It, the Game runs Perfect again but suddenly doesnt recognize that you have to Turn Off->On Experimental Mode and you have to Agree (Again) the Mod.io rules. THIS WHOLE Prozedure might cause the Character Customization Reset aswell.

6th Bug: with "Snaps back" i actually mean that when you fire both Rocket Launchers, the Weapon Yeets itself Backward behind your Character. Just go to 3rd Person mode and Shoot a Missile. You will see what i mean. The Bug exists in the Xbox Retail and Xbox Beta Version of SE.

And quick Reminder to Bug no 2.:

Please take the Time and investigate this Bug with the Ships that Sinks into Large/Small Grid Platforms and Voxel. I tested it with and Without Mods, with and Without Experimental Mode. The Result was allways the Same. The Ships keeps Sinking through Voxel and Grids all Types. I want to Add some other Things: Sometimes the PLAYER Character also Fallung Through Large/Small Grid Vehicles, when they moving above 60m/s. I discivered that over one Year ago (and before the Xbox Version git Modding Support) and thought that might be a Rare Bug that isnt Worth to report, but since the Last months the Bug appeared very often. I suddenly Falling through Blocks (if my Ship has a Grav-Generator) that is Moving more than 60ms. It also Hapoens much more when i use Speed mods and Flying with more than 200ms. So olease i repeat it probably to the 100th time: Please, look at the Bug and fix it. Im VERY sure that ships falling through Voxel or Base/Ship Landing Platforms isnt a Feature. It is terrible Annoying when the Damage is One the Ships shredding itself because when they already half below Voxel or Olatform, the Collision kicks in the the game's 60 Frames per Seconds turns into 10 Frames per Minute OR, when Damage Off, the Same occurs, Subgrids that are Attached on the Ship via Hinges or Rotors (for examole as a Ship turret) detaches themselves and the Ship (no matter what Size) turns into a Deadly oversized Projectile that Often yeets itself into the Orbit (if it was landed before on a Planet)

You guys can test it yourself, just Build a Very Large (and/or Long) Plate of normal Blocks and let it then fall on the Ground (do it on Planet Gravity) either on a Landing Platform or Mobile Large/Small Grid Platform, and on the Planets Voxel surface. It should directly sinking Through Voxel. If not make the Olates Heavier, build some very Heavy Blocks on to of it. Thats the Best example that i also Had (of course my Ships arent Oversized Plates, they have Landing Gears that are Below the Ships Keel. But stilly the Gears getting Vomid into the Voxel or Platforms.

So from ALL BUGS i reported so far, the Second Bug is the Most Important Bug that needs to be Fixed. Without this being fixed is the Game just Half enjoyable and also Half Unplayable, because almost All my Ships are build to land on Olanet Surfaces, but with The Bug...

They are Useless.

photo
1

Hello Engineer,

We'd like to assure you that we're very much aware of the falling through voxel issue and it's our top priority to fix.

Thank you.

Kind Regards

Keen Software House: QA Department

photo
1

Thats some Good news i like to read.

photo
photo
1

Hello Engineer,

Unfortunately we don't offer mod support, so we really can't do anything about the issue number 5, it does look like you're resetting the game to default.

Thank you.

Kind Regards

Keen Software House: QA Department

photo
1

I meant the mods you can download from the Gamebrowser/mod.io. THIS kind of Mod support.

photo
photo
1

Hello Engineer,

On the topic of issue number 6, is the character standing, flying in a jetpack or floating? Are you using a male or a female skin? Are you using any mods when you experience that issue? Are you using a RO-1 or PRO-1 rocket launcher?

So far we've been unable to reproduce the issue, a video would really help.

Thank you.

Kind Regards

Keen Software House: QA Department

photo
1

Both flying and Standing. Floating (for examole in Space) wasnt tested. Male. Yes, i used mods with it, but the Bug also still haooens without. The problem is that the missile Launchers sometimes suddenly work as intended. I will make a Video soon (soon because i am Currently not at home on my Console to record this)

photo
Leave a Comment
 
Attach a file