Workshop Blueprints not showing up and crashing the game

Andrea Morgione shared this bug 3 years ago
Outdated

Hello,


I've already submitted by problem, technically, but I believe I explained my problem poorly afterwards and probably in the first place, too, so I'm going to scrap my previous plea for help and try again. So: upon opening the Blueprints menu in-game only my local blueprints show, with the Workshop content being completely absent. The Cloud content, a whole two ships, doesn't show either. My Workshop subscribed items are thousands, which could admittedly be a problem, but the previous menu (pre-airtightness improvements) worked fine, if a bit laggily due to the sheer amount of blueprints. Now the blueprints don't load at all and the game overflows the RAM, overworks the CPU and crashes horribly after a few minutes. I've been suggested to delete the thumbnails from my pc since they may be slogging the process, and I've done it, but it didn't work. Guys, I cannot possibly unsubscribe from thousands of items because the "new and improved" menu (which is admittedly better than the previous, if it only WORKED) can't handle it. At the same time, these problems are an obvious deal breaker, and I haven't been able to play the game for months, literally. Is there any hope?

Replies (2)

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

Alright just a little more information from this bug: it's totally because the menu stupidly tries to load all blueprints at once instead of using the old method of creating a list and then loading on the fly. I have the admittedly whopping amount of 28.5 gigabytes worth of mods in total, so barring planets and the rest i'd say a good 18 gigabytes or more are ships, so obviously my 16 GB of RAM can't take this. Any chance we can revert to the old loading system or find a workaround before long? I really miss playing this game.

Leave a Comment
 
Attach a file