Withdraw components shortcut not working through hinge.

Jake Carruthers shared this bug 2 years ago
Reported – Awaiting fix

The shortcut (middle-mouse button) for withdrawing components for the item in the build planner does not work through the conveyor port on a large grid hinge block. The deposit all components shortcut does work however, and components and ore can pass through the hinge block normally. Video recording of the bug is here on Youtube.

Replies (4)

photo
1

This might be by design - it also does not work through piston heads or rotors. I'm hoping it's NOT by design, because it's annoying, but I began to observe it just before the 1.195 release.

To clarify the problem a bit: You cannot Deposit or Withdraw directly through the Conveyor interface of a piston, rotor, or (now) hinge block using the build Planner shortcuts (Middle click, Alt-Middle click). If you attach, for example, a Connector to that conveyor interface, then you can do so through that connector's interface just fine.

photo
1

Last I checked (which was before the major update), the shortcut doesn't work for pulling from any ships connected via connectors either; it appears isolated to the grid the action is performed on. However, using the button after opening the inventory works with subgrids as well.

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

Hello, Engineers!

Thanks a lot for your patience. Issue you are describing was indeed successfully reproduced and put into our internal system. Hope it will get fixed soon and you will use build planner with joy.

If you stumble across anything else, don´t hesitate to write to us again.

Kind Regards

Keen Software House: QA Department

Leave a Comment
 
Attach a file