This object is in archive! 

Unsupported station works like enabled when is disabled

szczepix shared this bug 3 years ago
Not a Bug

When I disable Unsupported Station in advanced menu and load game grids still not turn dynamic when disconnected from the static grid.

Comments (6)

photo
1

Looks like "Unsupported Station" feature not work. 😢

photo
1

@KeenSoftwareHause Have you any plans to fix it or remove from game or something else?

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

Hello Keen,


I have been observing this bug for months already. Unsupported stations is turned OFF for sure, and this problem appears to be elusive and is highly frustrating to solve. As a result, my Storable Hangar Bay doors (link here: https://steamcommunity.com/sharedfiles/filedetails/?id=909634127 , for the devs) do not work properly anymore.


The problem is as follows: when I bring up the rotor arms, I can attach the doors, no problem. However, after closing them, and opening them again, I can reattach them to the rotor arms, but the 'door grids' automatically flip to station mode! I cannot begin to explain how frustrating this is, as there is no way to work around it besides slapping a flight seat on it and manually setting it right. It cannot be done by timer block also.


I want to know whether this is a 'known issue' with Keen. It keeps popping up, also recently, if you look at some user reports. It would also give me some peace of mind, as I really want to have this fixed. It blocks critical and highly interesting builds at this point.


Keen Support: feel free to try out the thing I linked in the workshop. Remember the bring the doors up. After that, activate the 'hinge blocks'. After that deactivate the 'arm blocks'. The doors should look. Retract the arms and close all the doors. Then do the same thing in reverse. You hopefully notice that after reattaching the doors to the doors, the issue comes around the corner. I say hopefully, as it appears to differ for every user.


If you guys need some more data from me client side, please let me know.

photo
1

The problem here is that any grids over 256 blocks are not converted to dynamic.

It was done for performance reasons, but if we wanted the performance, we would simply turn on "Unsupported Stations" to begin with.

photo
1

That would explain a lot. This information to my knowledge is not public though. I never read about the 256 blocks restriction until now -.-.

photo
3

It was explained by the product manager himself the other day, over at this issue: https://support.keenswh.com/spaceengineers/publictest/topic/unknown-version-static-grids-not-falling-when-disconnected-from-voxel


I confirmed it by looking at the decompiled source code.

photo
1

Still doesn't work as it should. and we are many months further by now. A small test rig of at maximum 100 blocks still gave the same problems.


Right now, it is impossible to connect 'bigger doors' by means of merge blocks, as the moment you want to move them the other way around, the grid you want to detach floats like a station grid, while it should be dynamic! This needs to get fixed asap.

photo
1

Hello, Engineers!


Thank you for contacting us. However this feature currently works as implemented. Current behavior:

- if there is no collision with voxels in grid bounding box and you convert the grid to a station, divided grids will be always static

- if there is collision with voxels detected only max 1024 block splits might be converted to dynamic grid


Please post your suggestions of changing this feature to a Feedback section.


Kind Regards

Keen Software House: QA Department

Replies have been locked on this page!