Turret range issues

David McDonough shared this bug 21 months ago
Need More Information

I first noticed this with a mod turret, that when set to 4km it would not engage target until it got within 800m. But after bringing it up in discord, I was made aware that it only updates range on init, so cut-pasting the grid necessary after any range slider adjustment.

I don’t know if these are technically the same issue or not, but I am getting hounded on my Workshop for it. Please fix. :)

Comments (2)

photo
1

I've noticed the same behavior as well with this.

photo
1

Hello,


Could you please provide us with more information regarding the issue you reported? To report a bug into our system it is necessary to have reliable steps to reproduce in order for programmers to fix it. It would help if you could be more specific (specific mod, exact settings, etc), does it affect only modded turrets?


Any additional information would be greatly appreciated!


Thank you.


Kind Regards

Keen Software House: QA Department

photo
1

It affects all turrets, but it is more noticeable on modded turrets because people don't typically turn the range down and test. They turn the range up and try to engage at max range.


This is a basic modded turret, the one that this issue became most obvious to me with:

https://steamcommunity.com/sharedfiles/filedetails/?id=1686252385

The range can be set to 5km.


Steps to repeat: Adjust range of any turret, see that it does not actually reflect the slider's new value when tested.

photo
1

Must've been fixed or it doesn't happen in SP, I just tested a turret with an enemy decoy nearby, turning down radius under the distance they're at makes it stop shooting and idle.

photo