Station detaches from asteroid when grinding (modded?) blocks

antriot shared this bug 2 years ago
Outdated

Hello,


I've encountered a problem with stations on an asteroid. When grinding some modded blocks, the whole station seems to detach from the asteroid and moves slowly, even though it should have enough connections left. This results in a lot of Clang. The problem only seems to occur with modded blocks, but not all of them are triggering the detachment.

I have attached a save file where you can reproduce the bug. One of the relevant mods is "Kolt - Command Console Pack" (https://steamcommunity.com/sharedfiles/filedetails/?id=436025957). Grinding the switch, which is marked with "[BUG Switch]" on the hud will result in disconnecting the station from the asteroid. You should spawn in front of the switch.


What I have tried so far:

- restarting the game and reloading the save,

- repairing the save file with the SEToolbox,

- shooting the block with a rifle until the block is destroyed. This results in something like an explosion which damages near blocks, but the station stays connected to the asteriod.


If you need further data or information, please contact me.


Hail Clang,

antriot

Comments (8)

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

Hello KSH-Team,


I've done some more tests and the problem seems to concern not only some modded blocks, but also standard blocks from the game, like the light armor block. Also I checked if the station was unintentionally converted in a ship, which was not the case.


Best regards,

antriot

photo
1

Hello,


I encountered the same issue in my main world.

I have a huge base fixed to an asteroid. If i grind down one block, most part of the base become ship catch by asteroid with massive lag issue and co.


I've try one other world, didn't happen but i have only one world with big shipyard.


I've made some test to find what could invoque clang.

Origin parameter : survival / uncheck convert to station / unecheck unsupported station

With or without mod doesnt change anithing.

Happen in both survival and creative mode.


If i check convert to station, when base become free, it's not possible to convert back to station (i guess because movement and laggy in stone).


The only thing that stopping the clanging for the moment, is to check unsupported station.


Best regards,

Theodeathne.

photo
1

Hi,

I'm having the same problem with an out-of-place solar panel. Grinding it breaks my base away from the asteroid and damages the blocks that used to be in the asteroid. It seems to be converting my asteroid base into a ship for some reason. It does the same thing if I try shooting the solar panel with a gun.

photo
1

Has this been looked into yet?

photo
2

I have it too.


It happened when I was using all 3 symmetry planes in creative and I tried deleting a single block on my asteroid base.

The entire base just disconnected itself from the asteroid and tried to fly away, even though it's still labeled as a static grid.


The base was correctly anchored to the asteroid and the block I deleted was nowhere near the anchor points, so it just happened for no reason when I deleted a random block.

photo
2

Just got the same problem, each time I grind a block, vanilla or modded, the station moves away and I can't use SEtoolbox anymore to try to repair this by for example deleting the asteroid. No workaround found for the moment (I can upload the world if necessary for debugging)

photo
1

After try to add a big airtight hangar door who work with merge blocks and stuck against the requirement to disable unsupported station, i try to find if the size of the station can be what trigger Clang wrath.

So try after try, i remove part of the station, write info nb block/physic shape/pcu/triangle, reload world without unsupported station option and split a block and see what happen.

And i find a point where Clang stay calm.

I dont find the exacte thresold but during my split iteration i land at this :

_______Clang _|_ No clang

Blocs : 9109 | 8678

Shape : 5005 | 4815

PCU : 26619 | 25608

Triangle : 8721898 | 8534150


In non-Clang state i to try to reach bloc and shape value as in Clang state and grind down but nothing happened.


I hope this could help for investigation.