Splash screen should not load until after it initializes the Steam API

Gwindalmir shared this bug 3 years ago
Outdated

I have an issue with the splash screen delaying startup.

Here's the scenario:

I have the launch options in Steam set to -nosplash

However, I have a shortcut created by pinning the running application to the task bar.

When I launch the shortcut directly (or the exe from Explorer), it doesn't have the -nosplash argument set, as such it shows the splash screen... and waits for it.

Then it detects a launch from outside steam, and relaunches from Steam with the proper option.

So the splash screen was loaded for nothing. In fact, if I didn't have -nosplash set in Steam, it would have loaded the splash screen twice, with twice the delay.

If I set the -nosplash argument on the taskbar shortcut, Steam pauses the launch asking for confirmation of the launch options.

What I'd like to see changed is that the splash screen should not load until after it initializes the Steam api, thereby bypassing this issue.

Comments (1)

photo
1

Hi,

Why are you not using shortcut created by Steam?

photo
2

Because the Steam shortcut cannot be pinned to the taskbar (for quick access).

photo