SOME ship drills cannot mine boulders

Brian Collins, Jr shared this bug 16 months ago
Won't Fix

So, this seems to be a similar issue to some that have been reported, but with a catch:

In the save file attached, I have two vehicles in front of a boulder. The ROVER is one that was built (scenario is Splitsie's Survival Impossible with some additional mods added).

This rover is, suddenly, unable to mine boulders. It appears to be able to mine snow and rock just fine, but not boulders.

The yellow Atmospheric Miner was spawned in using Creative mode once the bug happened. It is able to mine the boulder just fine.

I attempted to copy/paste and cut/paste the rover, remove and re-add the drills, etc, no change... it is completely bugged.


This is probably the fifth or sixth time I have run into this sort of issue in Single Player, ranging from vanilla, no mods, all the way to mods that change resource spawning and add ores.


Keen, please dig into this - it is making the game nigh-unplayable!

Comments (3)

photo
1

Hello, Engineer!


Thank you for your report. Unfortunately there is no attached save. If you are having difficulty attaching files you can optionally use Google Drive. When sharing a google drive link please make sure it is set to be downloadable by anyone with the link.

Thank you.


Kind Regards

Keen Software House: QA Department

photo
1

My apologies - I had attempted to attach the .rar file. Let me try again.

photo
1

My apologies - I had attempted to attach the .rar file. Let me try again.


There we go. Of interest - it appears to only effect a boulder once it has been hand-drilled. I was able to mine fresh boulders just fine.

photo
1

I can confirm this bug. Rover built in the same scenario using procedurally generated ore. No amount of rebuilding works. Additionally, I used creative tools voxel hands auto leveling feature to remove the boulder and it could not. The voxel hands didn't recognize the boulder at all.

I would attach a save, but I don't know what file that is.

photo
1

My rover wont mine surface rocks on earth. The drill is attached to some rotors, pistons, and hinges. Very sad.

photo
1

So, I have the bug again, in a different save. It was working fine, mined some boulders (though oddly enough, the drill on my miner could ONLY mine boulders - it couldn't mine normal ground).

Saved and exited. Came back to play some more... and bam, can't mine boulders again, but I can mine the ground.

photo
1

please delete this message

photo
1

I have run in to this bug as well (same scenario), but have something new to add, I was traveling long distance via rover and noticed the boulders were "moving". I was running into the same boulders I had seen and mined from earlier, I have even saved/quit/reloaded and still had two boulders of the same "I had mined from them" kind side by side. I have even had them just outright disappear after a save/quit/reload, along with all the trees within the render distance of that location. Can try to pass out the save file, but I'm not sure where it is, I will have the GPS locations in an in-game text holder thing but I'm not sure if the rocks will still be there.

photo
photo
1

Hello, Engineers!

I appreciate this thread is quite old. Is this still an issue that persists or has this since been resolved? If resolved, I will close this thread for you :)

Kind Regards

Laura, QA Department

photo
1

Hello, Engineers!

Because there is no new comment from you, and we are unable to reproduce the issue on our own, I will close this thread now as outdated.

If you or any other player will experience this issue again, please make a new thread and provide all needed info there.

Thank you for understanding.

Kind Regards

Keen Software House: QA Department