Small grid tanks/fighters severely jittered when hit by bullets. Unusable in combat against turrets.

Daze Dream shared this bug 48 days ago
Need More Information

So I've been having lots of battles in my PvE server and one thing thats holding me down completely is that small grids relying on forward firing weapons are utterly incapable of aiming at the target once enemy turrets start hitting it. Wether it's the bullets themselves causing jitter or blocks breaking or bits of scrap interacting with the grid, my aircraft and tanks will jitter 30 degrees in random directions a few times per second and from that point I lose all control of the plane or tank, even if it can take the damage for a long time and still work fine. This jittering really needs to go.

Comments (1)

photo
1

Hello, Daze Dream,

thanks for letting us know.

However, when I did try it, I was not able to reproduce this issue. You think it might be possible to share me a safe file, where this issue can be observed, please? Are you playing online on dedicated server, Lobby (online option when starting new game), or is it observable also in single player?

You can access your save files by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers\Saves. There should be a folder with your SteamID and your saves.

Please zip the file and attach it here. If you are having difficulty attaching files you can optionally use Google Drive. When sharing a google drive link please make sure it is set to be downloadable by anyone with the link.

Or if that is the safe of world on dedicated server, do the same steps, just follow SpeceEngineersDedicated folder.

This is the best way how I can check the issue, in some world that it is already broken in.

Or as you are writing it´s happening on the server, when you are not able to share the save file, please you shall be at least able to do a blueprint of this grids (the one with the turrets and the ship/tank).

Thanks in advance for your reply and for providing the files.

Kind Regards

Keen Software House: QA Department

photo
1

We're playing on a dedicated server hosted by my friend. I've attached the file he gave me.

Some details for getting in (sorry for inappropriate names)

Our faction: Organic Gamer Harem (should auto-accept join requests)

Spawn point: Rat Cave Deluxe

There are lots of jets lying about in our base named SU87 Defectors, they are the ones I've been using to fight "arrowhead" enemy fighters and the bases they come from. Il also post a video here of the jittering I experience while getting hit.

Our server is down at the moment but it's usually up 24/7. You can join the server for testing there if it makes any difference, ll let them know you might come to test and you can take any of the defector jets.

Server name Robot Hell / MitchEngineers

Password: ass

photo
1

I've recorded one of my fighters that shows the trouble I have with jittering and attached it to this reply.

photo
1

Hello, Daze Dream,

so I did try it in all possible ways - single player with these two ships put in using blueprints, Lobby multiplayer, dedicates server from the save with and without mods, my new dedicated server... and I did not experience this.

I might say, that the ship "jittered" a bit depending on where I got hit - to the wings, it was obviously bigger. But never ever did I experience so unsteerable situation like you are showing on the video.

May I ask if that is happening only to you or to all players on the server? Only on this server, or you are able to make it happen also in other games/game modes with same ships?

If it is happening only on that one server that your friend is running and it is happening to all players there, I really might need to come there and see for myself.

If that is happening just to you and not to other player, are you able to find any "breaking" point, some e.g. settings that you are having different?

Literally any other information would help me. So please if you spot some difference, or some other info that you can share, do that. I would be very grateful.

Kind Regards

Keen Software House: QA Department

photo
1

I've asked my friends and they say they don't get this jittering, it's only me and only on that server. I tried on a offline creative world and I'm not getting jittering with the same jet. I've yet to test on another dedicated server though but I dont know where I could do that quickly. I think il try reinstalling the game, I've had this game on my PC for many years straight it might be holding onto something old. Can I do that without losing my worlds and blueprints?

photo
1

Hello, Daze Dream,

sure there is an option! :)

Please locate those by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers\Saves (Blueprints).

From there, just copy the folders with your saves/blueprints to some other location to back-it-up, reinstall the game and after that, locate this folder once again and copy-paste these folders with you saves and blueprints back to this folder.

You shall be able to see them in the game once you run it.

Please let me know if anything change after you do try this. Or whether the issue is fixed completely for you.

Kind Regards

Keen Software House: QA Department

photo