Ship RUBBERBANDING after leaving connector (repeatable)

Nick Tolbert shared this bug 5 years ago

Alright, So everyone looking at this knows the issue at hand, Disconnecting from the connector or either a large grid with a small shit or ship with station etc. I think ive figured out the changing factor that makes this bug happen.

(Also this is on a hosted server from a friends PC)

So I was HAVE been using solar and battery to power ships, finally got some Uranium and it seems that using small reactors with or without batteries gives me this issue.

My base doesnt have any sort of reactor, purely Solar and battery. When Ive been connecting to my base with any ship that has a SMALL Reactor, it gets the bug.

First it will just fall after disconnecting from connector. (no I dont turn off my engines, EVER. I know that is also a common reply to this) And the Ion thrusters just wont want to thrust, they sit idle the whole time.

If I F5 and rejoin the server, my thrusters now have thrust but I am stuck with rubber to the location.

I was able to get a landing gear installed on my ship, this allowed me to turn off my thrusters and using the gyros, "hop away from the rubberbanding area". However, after turning on my thrusters again, regardless of distance, the rubberbanding zone has just moved to my new location instead. {Keep in mind im on the moon so gravity lets me do simple things with large small-grid ships}

Okay so Im fairly certain using the following you will also get to experience the rubberbanding effect:

Step 1: Build a powered station using either battery or Solar only. No reactors

Step 2: Build a small-grid ship using Drills, battery, ion thrusters, SMALL reactors. (Also, conveyor runs through entire ship with the reactors also being tied on a conveyor block not directly to the storage)

Step 3: Connect the small ship to the station/base with a connector using its default settings.

Step 4: Disconnect from base while piloting ship.

Replies (10)


Is this a issue you have over and over again or a one time thing? I followed the steps as shown but never had any issue. If this is a issue you have a lot perhaps a upload of a save world would be helpful.

Have you had this on single player or only on multiplayer?


I do have the same issue but i did not use any reactors and as far as i concluded, the problem lies in the server thinking the ship is on point A but the client sees the ship at point B. Which causes desync and the rubberbanding. This issue is always fixed after a restart.

Sorry for types, cant see what im typing since i can only see the blank comment field and connect see what im typing.


Hello, Engineer!

Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.

We really appreciate your patience.

Kind Regards

Keen Software House: QA Department



I have the same (or similar) issue. Dedicated server, Moon, base only with solar and battery. Small drill ship with small and large reactors (not connected to anything) works fine. Large ship with large reactor battery and solar panels got stuck on connector even after grinding off the connectors and attached block. A server restart helped! Also had similar effects with landing gears. Both on small and large ships. Had to grind it off to fly away!




Had you use "P" key for disconnecting the ship?

Or is that ship's landing gear "Auto lock" enabled?

Some user in my Multiplay game had this issue sometimes.

They had 2 same behavior about this issue.

[Using "P" key to disconnect]


["Auto lock" enabled Landing gear]

I never use "P" key because it disconnect all connecters,

So I assign each connector and landing gear groups to Cockpit and

use it instead of "P" key.

And after use command instead of "P", I never had this issue.

(Korean community calls this issue "Magnet bug" btw.)

I doubt this issue kind of desync or packet lose or connection between DS and client. Likes we see the ship is disconnected but server actually doesn't.


Hi I'm having a rubberbanding issue. I created a small welder ship. I tested it for a few mins for around several km with no issues then docked on a connector then re-did the flight test - flew around my base, no problem - I re-docked onto the connector.

I was happy with my ship. Since it was a welder ship I needed to do some welding - so loaded up my ship with 300 steel plates. I disconnected from the connector and plummeted about 4 metres to the ground. There was no damage. I unloaded the steel plates and tried to fly but it seems stuck to the ground I can get off the ground but can only go about 50 metres befor I am pulled back to where I crash landed.

I did this twice so its repeatable.




Same thing happened to me today, and once to a friend a few weeks earlier.

On both occasions, with a dedicated server.

First time, Large base (station), on earth-like, small grid ship (battery powered) when disconnected from the connector wouldn't leave the area. Rubber banding back to connector. I couldn't see him going anywhere, he had to restart client side to fix the issue while I waited, he got free but it appeared we'd desynched so I had to also restart client side to fix it.

Todays occurrence, I was online, same server, alone. Large grid ship, docked by landing gear to an asteroid in 0.06g. Attempting to disconnect a small ion driven ship (reactor powered), from the large ship connector locked my controls and stuck the ship in place. Turning off both connectors seemed to free it, but the small grid ship immediately spun out of control.

I had to use gyro override to regain control, but then was sprung back 100m into the place where I first regained control as soon as I tried to use my drills. This kept happening for about 5 minutes, until I exited the cockpit and re-entered.

For that same session, every time I tried to undock with the connector, the ship would spin out of control, I'd gyro override, exit the cockpit and re-enter, then could go about my business normally, until the next disconnection.


Bump- this issue has still not been addressed for some reason ( too busy creating dlc to sell maybe? ). I quote:

"toggling thrusters on after being off while docked in a multiplayer server causes you to rubberband back to where you were once you launch, sometimes after minutes of flying around. Bug reports all over the place listing how to reproduce it and people (and me) still experience it... Keen never said anything about it, still a problem. Gotta get out of your ship and back in it every time you turn thrusters on or it might rip you back onto the connector."



I am also having this issue but it is a little different. I have battery powered Hidrogen mining ship and our base has a small reactor. It will not allow me to disconnect and continues pulling me back in. Blue ring never goes to white but pulls me back in and turns yellow again. Sometimes after a bit of exiting and entering the cockpit and hitting P again it will disconnect. At times however it will go bezerk and shoot me back at max speed untill my ship crashes into whatever is behind me. I have no control during this time and I have lost two big ships that I have put a lot of work into. Luckily I save the BP. This is a horrible issue and needs to really be looked into. Next time it happens I will record it.

Leave a Comment
Attach a file