This object is in archive! 

Server crash when 2 ships collide with landing gears!

Yuri shared this bug 2 years ago
Won't Fix

2020/08/26 17:10:48.025 [FATAL] Initializer: System.NullReferenceException: Object reference not set to an instance of an object.

at Havok.HkEntity.get_InWorldInternal()

at Havok.HkEntity.get_IsFixed()

at SpaceEngineers.Game.Entities.Blocks.MyLandingGear.CanAttachTo(HkBodyCollision obj, MyEntity entity, Vector3D worldPos)

at SpaceEngineers.Game.Entities.Blocks.MyLandingGear.FindBodyResult(List`1 penetrations, Vector3D tempPivot)

at SpaceEngineers.Game.Entities.Blocks.MyLandingGear.<>c__DisplayClass65_1.<FindBodyParallel>b__1()

at Sandbox.MySandboxGame.ProcessInvoke()

at Sandbox.MySandboxGame.Update()

at Sandbox.Engine.Platform.Game.UpdateInternal()

at Sandbox.Engine.Platform.Game.RunSingleFrame()

at Sandbox.Engine.Platform.FixedLoop.<>c__DisplayClass11_0.<Run>b__0()

at Sandbox.Engine.Platform.GenericLoop.Run(VoidAction tickCallback)

at Sandbox.Engine.Platform.Game.RunLoop()

at Sandbox.MySandboxGame.Run(Boolean customRenderLoop, Action disposeSplashScreen)

Replies (9)

photo
2

Hello, Engineer!


Unfortunately we are unable to reproduce the issue. Can you please provide more information to reproduce the issue? Also whole log would help!


Kind Regards

Keen Software House: QA Department

photo
2

Hi, it's not simple to reproduce this, but it's happened already 6 times in last 10 days.


Issue is at server!, players fighting with NPC ships, and sometimes NPC or players ramm each other.

Now players have landing gears pointed forward to catch the npc ship and to grind it, so when that npc ships smash at high speed in too player ship, both ships merge! SIM is dropping to 0.2 and after few sec they bounce and when they do, landing gears trying to attach! but for some reason there is a fail there.


Also this can happen when player traveling with high speed and cant stop and smash in to voxel or other base, while landing gears point to that vector and have auto lock enabled!


So ships crash and bam, server crash.

This error in logs.

photo
2

Here one more right now.


2020/08/27 12:48:12.294 [FATAL] Initializer: System.NullReferenceException: Object reference not set to an instance of an object.

at Havok.HkEntity.get_InWorldInternal()

at Havok.HkEntity.get_IsFixed()

at SpaceEngineers.Game.Entities.Blocks.MyLandingGear.CanAttachTo(HkBodyCollision obj, MyEntity entity, Vector3D worldPos)

at SpaceEngineers.Game.Entities.Blocks.MyLandingGear.FindBodyResult(List`1 penetrations, Vector3D tempPivot)

at SpaceEngineers.Game.Entities.Blocks.MyLandingGear.<>c__DisplayClass65_1.<FindBodyParallel>b__1()

at Sandbox.MySandboxGame.ProcessInvoke()

at Sandbox.MySandboxGame.Update()

at Sandbox.Engine.Platform.Game.UpdateInternal()

at Sandbox.Engine.Platform.Game.RunSingleFrame()

at Sandbox.Engine.Platform.FixedLoop.<>c__DisplayClass11_0.<Run>b__0()

at Sandbox.Engine.Platform.GenericLoop.Run(VoidAction tickCallback)

at Sandbox.Engine.Platform.Game.RunLoop()

at Sandbox.MySandboxGame.Run(Boolean customRenderLoop, Action disposeSplashScreen)

photo
2

2020/08/27 13:09:52.170 [FATAL] Initializer: System.NullReferenceException: Object reference not set to an instance of an object.

at Havok.HkEntity.get_InWorldInternal()

at Havok.HkEntity.get_IsFixed()

at SpaceEngineers.Game.Entities.Blocks.MyLandingGear.CanAttachTo(HkBodyCollision obj, MyEntity entity, Vector3D worldPos)

at SpaceEngineers.Game.Entities.Blocks.MyLandingGear.FindBodyResult(List`1 penetrations, Vector3D tempPivot)

at SpaceEngineers.Game.Entities.Blocks.MyLandingGear.<>c__DisplayClass65_1.<FindBodyParallel>b__1()

at Sandbox.MySandboxGame.ProcessInvoke()

at Sandbox.MySandboxGame.Update()

at Sandbox.Engine.Platform.Game.UpdateInternal()

at Sandbox.Engine.Platform.Game.RunSingleFrame()

at Sandbox.Engine.Platform.FixedLoop.<>c__DisplayClass11_0.<Run>b__0()

at Sandbox.Engine.Platform.GenericLoop.Run(VoidAction tickCallback)

at Sandbox.Engine.Platform.Game.RunLoop()

photo
3

New information!


Player reported that he thinks that server crashing when he is changing active safe zone range and other ships inside the safezone attached with landing gears.


Last 2 crash came from this change.

I have disabled all landing gears in that safezone and no more crashes.

photo
2

The same problem, it happens several times a day/b51bedbd7e84f997c0185579372de1ad

photo
2

Same bug

photo
1

Hello, everyone!


Could you please provide us a save of your world (without mods) where you are experiencing this issue? We will appreciate any additional information. Thank you!


Kind Regards

Keen Software House: QA Department

photo
1

Hello Engineers,


Since there are no new comments in this topic, we are closing this thread as outdated.

In case anyone is encountering the same or similar bug, which is not already posted in a

different thread, please feel free to create a new thread with all relevant information.

Thank you.

Kind Regards

Keen Software House: QA Department

Replies have been locked on this page!