Rocket Launcher Exploit Rapid Fire

Vas Vadum shared this bug 4 months ago
Won't Fix

The new rocket launcher can be exploited to have rapid fire by putting both different rocket launchers in the hotbar and firing them by switching between them by switching back and forth.

I suggest a priming feature to have the rocket launcher take the full reload time to be ready to fire once you switch to it. In this case, it could be that if you put away the tool, it empties its ammo back into inventory, or drops the rocket into space if not enough inventory space. Basically, the rocket can't be loaded without it being currently held.

Then switching to it, will switch to an empty rocket that needs to be reloaded. Switching from one to the other, unloads the rocket you just held. Thus removing this exploit in the simplest way.

Comments (5)

photo
1

Hello, Vas Vadum!

Thank you for letting us know about this. I have successfully reproduced and reported the issue internally.

Kind Regards

Laura, QA Department

photo
1

unknown

I knew it :o)

photo
1

Some gift of foresight there.

photo
photo
1

It's only in creative. Where, you know, everything "just works" and there's no need for ice, uranium, hydrogen, ammo, power, etc. The fact you can spam the rocket launcher ... is a problem? (Genuine question) Are there actual PvP servers out there in Creative?

photo
1

No, this was in Survival. I tested it in my survival world. It may have been patched by now, but I don't know.

photo
photo
1

I feel really silly now, Patrick. All the weapon reloads work correctly in survival. Good job whoever implemented the weapon code! #FakeScandal

photo
1

He was wrong, I tested this in survival after it was reported in discord by someone who didn't want KeenSWH to know about the exploit.

photo
1

I switched my local world to survival and did my own testing. When you switch back the the rocket launcher or any other weapon that's out of ammo it restarts the loading animation.

Did you test this on a server?

photo
1

Then a hotfix may have already been applied. I tested this on the day I posted this, just 10 minutes before the post. I shot up my base with it and exited without saving.

photo
photo
1

Hello, Engineers!

As a lot of you mentioned, this is creative and not survival. I have received feedback that this will not be changed as it has no real meaningful impact as it is in creative mode. Apologies for this.

Kind Regards

Laura, QA Department

photo
1

Uh.... I didn't do this in creative. I did this in survival.... I used the admin tools to spawn both rocket launchers.

Do you guys even test this crap before you close a ticket? Or just look for any reason to close a ticket so you don't have to do anything?

photo
1

I just tested this and the exploit does not work in survival, even with creative mode tools enabled.

photo
1

Hello, Engineers!

I agree that this is also not working like this in survival for me and only creative. However, if you believe it is please provide a save file where this is happening :)

Kind Regards

Laura, QA Department

photo
1

When I originally reported it, it was happening in survival. Maybe something you guys did fixed it later. But please, don't mark it as "won't fix" and label it because its only in creative. It was reported from Survival, not creative.

That just ticked me off, seeing a "won't fix" label on a bug I reported and seeing it listed as "because its only creative". Besides that, even if it was creative, its still a bit of an exploit. Not that it matters as much particularly but, yes. Flag it as fixed if you want, if it seems to have been fixed in survival.

However. Its not fixed. I just tested it by going into single player survival, with admin creative tools enabled I spawned both PRO-1 and RO-1 rocket launchers. I put them both in the hot bar. I spawned in 10 missiles, loaded the rockets, both of them. I then fired one, switched to the other, fired it, in quick succession. (Excuse the possible mis-remembered names of the rocket launchers. I just glanced real fast to test, I haven't played the game for months now since I reported this issue.)


You mentioned a long while back you also replicated the issue yourself.

-- Also seriously, you guys need to contact UseResponse because this software is horrible. I have to hit Ctrl F5 to even refresh this crappy page to read replies and shit. (Clearing cache for the website every time I come here.) This particular bug has been around since you first started this subdomain.

photo
1

When is warfare 2 coming, i need more guns!!

photo