Restarting/Updating Dedicated Server "kills" me despite being in a cryo pod

LoneGunman shared this bug 2 years ago
Outdated

This is reproducible on my server every single time.

I'll play then put myself into a cryo pod on a ship or station with plenty of power (reactors with thousands of uranium ingots).

I'm the only player currently on the server so once I'm out, no one else goes on the server.

If I log back in later (hours, days or weeks), there's no problem. I load into the server and I'm in my cryo pod as expected.

If I restart the server (usually to apply a game update or a mod update), when the server comes up and I log in, I end up by a medical room. I don't get to pick a respawn location. The medical room is on my Moon base. The cryo pods I'm using are usually in orbit above the base, either on my orbital station or a ship next to it.

Also, my entire inventory, including tools, is usually wiped as well.

Because of mod updates, this can be a constant problem.

Replies (7)

photo
1

Just curious here, do you have at least 1 battery on that grid ? I suspect power glitches

photo
1

I have the same problem on the server I play on (Captain Jack’s, if you care). They have it set up to restart the server every 4 hours, so it happens A LOT.

In response to Puruska’s comment, yes, I have 5 or six DOZEN, fully charged batteries on this base, probably around 50 reactors (small grid, large grid, both small and large reactors) if you count all reactors that are docked to the base in the various ships, all of which have plenty of uranium.

Also have about 2 dozen O2 generators on the grid, with 12000k+ ice in storage. So it’s probably not a “I suffocated” situation

So yeah, looks like a bug..

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.


Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

So one suspicion I have is the autosave. The server I'm running is on Blue Fang and I suspect it pauses after the last user disconnects (usually me). Problem is, the pause also pauses autosaves (i.e. a user has to be connected to the server for autosaves to happen). I have them on a five minute cycle and I watched the logs after disconnecting the other night. No autosave at the designated time.


That said, I don't know for sure if it's strictly that. Usually when I update my server (and restart it as a result), I log in immediately afterward. If the problem was that the autosave caught me before I entered the cryopod, then technically I should rejoin the server and either a) be prompted to respawn (because, I don't know it considered it a very long disconnect and killed my character?) or b) drop me into my character wherever he is.

I need to clear my inventory in-game but I'll try to get an autosave to hit before I'm in the cryopod, disconnect, restart, and join back in to see if that reproduces the issue.

Problem is, there's supposedly an autosave on shutdown so technically it should've, under normal circumstances, saved me in my cryopod if that's where I was when I disconnected and the sim paused. But I guess we'll see.

photo
1

I had a mod I wanted to add so:

  1. I positioned myself outside of a cryo pod and waited for an autosave.
  2. I then put myself into the cryopod.
  3. I then logged out of the server.
  4. Shut down the server.
  5. Updated and uploaded the sbc file (actually two of them: sandbox.sbc and sandbox_config.sbc, seems the latter worked, former didn't).
  6. Started the server up.
  7. Logged into the game.
  8. Found myself down on my moonbase by a medical room; no respawn screen but inventory was empty like I'd died.

I tried another sequence:

  1. Left myself outside of a cryopod.
  2. Let the autosave happen.
  3. Disconnected from the server.
  4. Stopped the server.
  5. Restarted it.
  6. Logged back in.

And I was where I'd left myself.


Unless I missed something, it seems almost like if you're in a cryopod and the server restarts, cryopod states aren't being maintained but character states outside of the cryopod are being retained?

I don't know if there's anything special with my setup that might make me more susceptible to this. Seems almost safer to leave myself floating in space...so long as the sim pauses immediately I should be fine. lol

photo
1

So further testing seems to indicate it's less of an issue of the game randomly killing me. If I sit and wait while I'm in a cryo pod until the server log shows me that an autosave has occurred before I log off, I've consistently found myself alive after server restarts and updates (including the 1.193 update just released).


That said, I still think this is an issue. If the server is going to pause not only the simulation but autosaving and is not going to trigger an autosave prior to halting/pausing the simulation or shutting down the server instance (I think the former is safer IMO), then this will continue to be a problem on dedicated servers. If the game never needed to be updated (some kind of live mod install/update/reload and live patching), then I'd say there isn't much to worry about. Since that's unlikely to be true, I think this would be worth fixing.

Since waiting for a shutdown event would preclude factors such as server crashes, power outages, etc., why not just have the autosave timer run separate from the simulation?


You could have something where:

1) Server is running, auto-save occurs every 5 minutes, users are currently active on the server, sim is running.


2) Auto-save process hits it's limit (5 minutes) and triggers. Process checks is sim running?

a) If sim is running, set next auto-save trigger time (5 minutes in this case).

b) If sim is not running, do nothing. No more auto-saves will occur. (exit or pause auto-save process)


3) When sim is restarted (i.e. server start, new player joins), spin up the auto-save process.


Best of both worlds would be great (i.e. an additional auto-save attempt at shutdown if auto-saving is enabled). That would cover everything but I'll take what I can get... :)

photo
1

Same bug.


On dedicated server:

Enter cryopod, log out, restart server, log back in, insta death as soon as I exit the cryopod.

Leave a Comment
 
Attach a file