Post Update Particles are not properly disposed.

Shane Stixrud shared this bug 4 months ago
Solved

I am the author of WeaponCore and DefenseShields and since the most recent update MyParticleEffects are no longer properly disposed of when MyParticleEffects.Stop() is called. In fact after spawning enough particles, no additional particles are spawned and MyParticlesManager.TryCreateParticleEffect() will continue to return true and this remains true even after logging out to main menu and then loading a new game. I have also attached a video to show that particles are sticking around in world:

https://www.youtube.com/watch?v=nDVSbnfHjOo

Comments (5)

photo
1

Seems to be tied to loop particles. These particles do not free up when exiting to main menu and loading a new world. You must quit SE to see particle effects again.

photo
1

Hello,


Could you please provide us with steps to reproduce the issue you reported? To report a bug into our system it is necessary to have reliable steps to reproduce in order for programmers to fix it.


Any additional information would be greatly appreciated!


Thank you.


Kind Regards

Keen Software House: QA Department

photo
2

Install this mod (which heavily uses particles): https://steamcommunity.com/sharedfiles/filedetails/?id=1920388300

Add a ship with a lot of weapons. Copy past this ship a dozen times, make them enemies let them fight. After sometime particles will stop drawing. You will notice that even unloading the world and re-loading the world does not fix it. This worked without issue prior to the recent update.

photo
1

This can be reproduce by simply creating a world with enough damaged grids to generate 400-500 in world and then quit and reload the world 6-7 times. After reloading that many times you will notice that the damaged grid blocks no longer generate particles. The following script will also begin reporting lower values until they report 0 particles:


[MySessionComponentDescriptor(MyUpdateOrder.BeforeSimulation | MyUpdateOrder.AfterSimulation | MyUpdateOrder.Simulation, int.MaxValue - 1)]

public class Session : MySessionComponentBase {

public override void UpdateBeforeSimulation()

{

MyLog.Default.WriteLine($"{MyParticlesManager.InstanceCount}"); }

}

photo
1

when im drilling sometimes the spark particle effect doesn't go away and stays there for a little bit

photo
1

Does this still need more information or is it being worked on?

photo
1

heres how I found the bug --> my name on steam is _coolguy_10, I have a workshop item called DRILL, it a big drill and every so often the drill particles will stay floating in the air

photo
1

hopefully this is fixed very soon so mods that use a lot of Particles will work better

photo
photo
1

Hello, Engineers!


This issue is currently in progress. The fix will be included in a next major update.

Thank you for your patience!


Kind Regards

Keen Software House: QA Department

photo
1

Hi guys,

I hope this is right behavior of the modded weapons :-)

https://streamable.com/kbip3c


It should work like this in the upcomming patch.

Thank you very much for your feedback.

photo
1

Fixed in v195