Player Does Not Die on 0% Health

WesternGamer shared this bug 4 months ago
Reported – Awaiting fix

I was playing Space Engineers when I took damage and my player did not die on 0% health which does not make sense.

Comments (5)

photo
1

Hello, WesternGamer!

Sorry to hear you're experiencing this issue. Could you please give more information on how this happened? I seem to be unable to reproduce this issue as my character dies as expected at 0% Was this online or offline? Which scenario or world was this in? What were you doing when this happened? We would need reliable steps to reproduce the issue for this to be reported so any information to help us do this would be great :)

Kind Regards

Laura, QA Department

photo
1

So I was in a world on a station that had very high artificial gravity (400g) and I fell and the health was at zero percent. It was on an offline world. The world was the Empty World scenario. It is not easy to reproduce, so I have a world where the player health is at zero percent.

photo
1

Hello, WesternGamer!

Thank you for providing the save, I can see it is indeed at 0%! I notice if I then take further damage, I will then die. You say this is not easy to reproduce but unfortunately, I need to reproduce the issue to report it. Was it a case of chipping away health until you got to 0%? I tried that approach and got to 3% and the extra hit killed my character! I wondered if this was a fluke that enabled you to get to the 0% or if you can explain how to get there :)

Kind Regards

Laura, QA Department

photo
1

It was a case of chipping away health until I got to zero health. I seen this happen to two different people in videos. This happened to me at least 3 times before so I think it is not a fluke.

photo
1

Hello, WesternGamer!

Thank you for the confirmation. So far, I have not been able to get the health to land on zero. If you happen to find a reliable height that you know this will work with e.g. 'If you drop from X height 3 times' please let me know. It seems like this is quite a tricky one to try and reproduce! I will keep trying with this and see if I am able to get it at zero.

Kind Regards

Laura, QA Department

photo
1

This is happen when you really low HP, rounding error i guess

photo
photo
1

Hello, Engineers!

I have successfully reproduced the issue and reported it internally. I was able to find a sweet spot of being just the right height to get to 0% from WesternGamer's save. Thank you! :)

Kind Regards

Laura, QA Department

photo
1

Glad you reproduced it! I'm sorry that I couldn't help reproduce it for you but at least it will get fixed!

photo