Physics begins to break down at a certain point on a world of mine

AWG shared this bug 3 years ago
Outdated

After a few minutes in a certain world of mine audio begins to glitch, with loud popping noises and everything using wheels, rotors, pistons or subgrids begins to float and slowly rotate, ignoring gravity. The player also starts to shift, and it becomes impossible to walk on voxel terrain. I have attached a video.


https://www.youtube.com/watch?v=rUOpcKnu3HY&feature=youtu.be

Replies (5)

photo
1

I have the same bug! (In space)

Here's a zipped save file. Just wait a minute, and boo-oo-oom!

Only a skybox as mod.

photo
1

Any idea how to avoid or solve this? I haven't been able to play for a long time because of this.. :(

photo
1

Sometimes I have similar problem - playing on planet I cannot walk on armored slopes.


However, after I restart the game (or was it PC restart ?) the same world has the physics working again.

That's why I didn't yet created bug report, because provided world won't have the 'physics broken'.

photo
1

Phew, I found the cause i my case.. Posting it here so it might help somebody else here.

When this flexible conveyor was squeezed toghether it caused the physics going havoc. I just had to push it apart to avoid it. See picture.


d17f6e7aa95835d76d09ad3e8057a17f

photo
1

Hmm ... it isn't then similar problem to mine ... I don't use such physic-demanding contraptions because of clang ;-)

photo
1

I have the same exact bug as AWG, this happens on both my DS and me just hosting a game by myself. (And no my Firefly ship has not been the only origin of this issue as this bug has occurred several times before. And even before I actually built the ship the bug has come back several times)

This is my one consistent world it happens on if you do this:

1. load up the world. (duh)

2. Remove the Gatling turret on the ship you start at in my save (FireFly)

3. Place the Gatling turret back

4. Go into the cockpit of the Firefly

Now it will start floating away and your character struggles to walk anywhere on the ground

On a DS this happens as well if I land it and turn off the script controlling the rotors but the bug will also split any subgrids from their original point and they will also start to float away as well. (e.g. Wheels, rotorheads, and any subgrids will detach and float freely including other small ships in the area.) But this only occurs on the Earth planet. As if you go into space none of these issues apply there. Even the sim speed returns while in space.


So if the devs see this, hopefully they can track down what it is.

photo
1

With update 1.189.043.this was solved for me. Thanks!

"-Fixed misbehaving physics, where collisions became increasingly offset over time" could have been the issue..

photo
photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

Leave a Comment
 
Attach a file