NPC reputation on faction join

Oliver Pola shared this bug 4 months ago
Won't Fix

When I join a faction, the reputation to NPC factions (maybe players as well) is reset to 0. At least, this is what the GUI shows. Now after doing some of those reputation "resets" on an official server, I realize that there is one NPC faction, where it is now "reset" to -1000 when I join a faction.

Seems the reset to 0 was misleading me, and there is an actual reputation that remains unchanged on faction join but is not shown by the GUI. The one faction might have gone < -500 (or < -1000) in the meantime although the GUI was always showing something > -500 and that "internal reputation" might be the reason why "GUI reputation" now shows exactly -1000 when I join somewhere.

Background: I find the NPC reputation system quite unbalanced, as the sum over all reputations can only decrease over time (for each job you gain some rep somewhere but lose even more rep elsewhere). As the GUI made me think of this "reputation reset", I continued having fun with NPCs despite that fact. Without any reset, I feel forced to not do any NPC jobs at all, which removes some fun from the game.

Comments (2)

photo
1

Hello, Oliver,

thanks for letting us know about this issue that you are experiencing.

But I can not make it happen... the so-called "reset" of reputation is not happening to me.

Whenever I join some faction, do some quests for them, my reputation to that faction including its friendly factions are set correctly.

Let´s say:

I was part of Merciless Technologies, did couple of quests for them, the reputation rose to +50.

For all its friendly factions, the reputation towards them rose to +10.


Some factions were still neutral, leaving the reputation on exact 0.

One faction (The First Hauling Service) did not like my actions and the reputation dropped to -60.

There was no change in enemy faction Space spiders - still -1000.

Reputation with Space pirates dropped to -1093 (but I suspect that that was due to my other actions when not in any faction at all).

After leaving and joining random factions, the reputation still stayed the very same towards all factions in the game. No "reset" of the reputation value happened at all.

So sorry, so far no luck. And since you are mentioning it happened on official server, I suspect you are unable to send me the save file of affected world, right? That would be the best... so if you can try to replicate this issue also on dedicated server, in-game lobby online mode or single player, that would help tremendously!

If not, can you please try to provide at least a video, of what is exactly happening? There might be something that I didn´t understand correctly from the text itself, so seeing what is going on, what you are doing, where do you click etc., that would be great lead as well!

Thanks in advance for your reply and for providing the files.

Kind Regards

Keen Software House: QA Department

photo
1

Hello, Engineer!

Because there is no new comment from you, and we are unable to reproduce the issue on our own, I will close this thread now as outdated.

If you or any other player will experience this issue again, please make a new thread and provide all needed info there.

Thank you for understanding.

Kind Regards

Keen Software House: QA Department