Not possible to pull items through the yellow port on the "Medical Room"

EDGE shared this bug 3 months ago
Not a Bug

When accessing the inventory through the port on the Medical Room you can drag Items from one place to the other but when double klikking on it or Shift-klikking or Ctrl-klikking nothing happens. It creates confusion as this normally only happens if it's somehow not connected and can cause someone like me to dismantle the entire build in order to try and find the cause. To be specific, I've only tried this through the bottom port.

Comments (2)

photo
1

Hello, EDGE,

thanks for letting us know about your concern.

However, this is not bug as such.

If you try to play a little with the inventory system on your base/on some testing grid with just couple of cargo containers, conveyor sorters and medical room, you will see exactly how the game is working and why.

It is not possible to use the alt + , ctrl + and shift + click on the block that does not have inventory on its own. This method always needs to have some primary inventory on the block that you are working with.

You can e.g. pull some stone/ice/something from one container, and try to give it back to other one. You will observe that the method is trying to reach the native inventory of the currently used block. And since medical room does not have any, that is why "it is not working".

Only way how you can operate/change/pull from other inventories using medical room is to drag-and -drop with your mouse.

Will close this thread now.

Kind Regards

Keen Software House: QA Department

photo
1

I'm sorry but this still doesn't make any sense. What does this have to do with pulling stuff in to your suit through an access point? I'm not trying to pull it in to the medical room I'm simply using it's access point to get it in to my suit inventory. Also if I decide to take out a few hydrogen bottle out of the H2-O2 generator through a cargo container I'm not seeing it bounce in to the cargo container before it lets me put it in to my suit. Thirdly if try to do the same through the "Basic Refinery that does not have cargo space for hydrogen bottles at all, it's still letting me double klikk the bottles. Also double klikking is no different from dragging it from one location to the other so if it's ok to drag it why aren't we allowed to double klikk it or specify the amount. Playing around with it has not explained anything.

Replies have been locked on this page!