[Mod API] Damage API missing RaiseBeforeDamageApplied/RaiseAfterDamageApplied

My Dummy0815 shared this bug 23 months ago
Reported – Awaiting fix

I know this issues has been reported in older forums already but never been solved.

The modding API has no access to call the damage system in propper way, to notify about damage that has been applied by a mod.

So as this could not be called there is no way for 'shield mods' and the 'reputation' system to react propper on this damage, which is in my eyes a weak spot.

Hope you consider of allowing this.

Regards


//Not available in modding

MyAPIGateway.Session.DamageSystem.RaiseBeforeDamageApplied(target, ref damageInfo);

..

MyAPIGateway.Session.DamageSystem.RaiseAfterDamageApplied(target, ref damageInfo);

Comments (7)

photo
1

I have nothing to do with the author of the mod. Unless, I'm his subscriber. He currently has 59,078 subscribers, I think it would be nice to help this person a little, thereby helping us all. Thanks in advance KEENS p.s I apologize for my English. I'm from Russia.

Я не имею ничего общего с автором мода. Разве что - я его подписчик. В настоящее время у него 59 078 подписчиков в воркшопе, исходя из этого думаю, было бы неплохо немного помочь этому человеку, тем самым помогая всем нам. Заранее спасибо KEENS я прошу прощения за мой английский. Я из России.

photo
1

You and I share different beliefs in prioritization over bug fixing.

photo
1

Judging by how long this topic has been walking around the forums, for several years, if I'm not mistaken. Priority on this API 0%)

photo
photo
2

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

what is happening to this please

photo
2

how much longer will this sit here as considered?

photo
1

As this is still an issue I don't understand why it is Outdated now?

photo
1

we still need this

photo
1

Hello, All!

Thank you for letting us know about this issue. This has been reported internally,

Kind Regards

Laura, QA Department