Medical Room + Connector = Oxygen Supply Bug

J Karstin Neill shared this bug 2 years ago
Outdated

Hello! I am not sure if this specific problem has occurred for anyone else yet. I've tried to look it up multiple times but I am not seeing the same issue as what I am experiencing. The only reason I think that this may be a bug and not me just being brand new at the game is that the issue fixes itself after a game restart every time. This is pretty inconvenient, and I am hoping to possible get some clarity on the issue.

Some info about my setup:

My current ship setup has O2/H2 Generators that are all connected through the conveyor system. This system connects to a couple Oxygen Tanks as well as Small Hydrogen Tanks, Hydrogen Engines, Large Storages, Cryo Chambers, Assemblers, and Refineries. These all work as expected and everything seems to work fine. They are also connected to a Medical Room, and a Connector. All parts of the ship are owned by me and are shared with my faction.

What is happening:

When I load the game, I can walk to the Medical Room and get Oxygen at the Medical Room just fine. The same goes with Cryo Chambers. When I connect a small ship owned by another player (who has left the game without using a cryo chamber and is labelled as (dead) in the ownership bar of the small ship's control panel) to the Connector on my ship, everything works as expected. The small ship has no oxygen storage or oxygen supply, so no oxygen is needed to be given to the small ship. The problem occurs once I disconnect the small ship from my ship. Once this happens, I can no longer get oxygen from the Medical Room. I can get it from the Cryo Chambers just fine, and I can refill oxygen bottles in the O2/H2 Generators, but I can't get any oxygen from the Medical Room. What is strange about this is that connecting the small ship back to the Connector makes the Medical Room functional again as far as oxygen supply goes. If I disconnect the small ship again, the Medical Room stops providing oxygen. This is fixed if I restart the game after disconnecting the small ship.

Again, I am pretty new at this game, and I am still a bit unsure what the impact of Connectors and ownership has on how things are supplied, but this feels like it's not designed to work like this. If I am wrong, please let me know.

Thanks for your time.

Replies (3)

photo
2

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
3

We've discovered the same bug, on two different servers, connecting and then disconnecting a ship from a connector bugs the medical station and/or anything from supplying oxygen/hydrogen on the same grid (regardless of who owns the connected ship)

photo
1

Same issue on our server, has been driving us crazy. Can't tell if O2 is supplying because our base is on Earth, but hydrogen will definitely only supply to characters via the med bay when a ship is connected. Cryochambers are behaving the same way.

We tried every switch of ownership and connection troubleshooting idea we could think of, including connecting one of the H2 tanks directly to the med bay by its own dedicated conveyor tube, trying every permutation of H2 tank settings including building an entire large one to replace our 2 smalls, completely tearing down and rebuilding the bay more than once, and every combo of ownership options we could make sense of.

We also tried breaking the conveyor connection between the ship and the base, such that the ship is still locked by a connector but has no conveyor connection to the rest of the base network. Behavior remained the same, with H2 resupplying from the bay/cryo if the ship is connected to grid, and stopping as soon as it is disconnected.

Through all this, gas transfer between tanks, bottles, and the generator works fine, it's just facilities that supply gas(es?) directly to the character that break in this way.

Leave a Comment
 
Attach a file