Jukebox audio doesn't emit from its location

Skye Mors shared this bug 12 months ago
Won't Fix

"As of loading my game and world today, the Jukebox I had set up no longer emits music from itself, but instead from a point just to my right in any orientation."


"Hello. This bug is not easy to pin down, and still occurs. On both world audio modes, it will unreliably be merged into Mono, and in only one ear (properly and fully explained in... uh, somewhere above), both vanilla and modded.

At first I thought it was a hardware issue on my end, as Logitech has Surround Sound issues, but I can assure that my 7.1 Surround Sound is working flawlessly, and that it is indeed an issue with the location and distance tracking for the audio engine, or similar.


As an update, I've been playing in a Realistic Audio world, heavily modded (with added music), and I've got some more info for you guys to use:

1: When a song starts playing after loading a world or manually changing songs, it will play in the aforementioned broken mode with no tracking and in a 10 - 90 Left - Right audio split no matter what.

2: When a song finishes and the next song plays, it will play in Stereo (I had to grab a mod with true Stereo songs to test), with the technically proper 50 - 50 Left - Right split... but again, there's no locational audio tracking. The song auto-switch also applies to when you leave the audible area of the jukebox (including jumping in a vacuum). This part is expected, but annoying, especially with actual songs.

I would love for the Jukebox itself to never go to 0% volume, and instead only to 0.1%, making it continue and not restart or switch songs every time it's interrupted.


I understand that 2020 was rough, and that your team is very small, and appreciate the work you guys put in to both fixing bugs for the community and adding tiny content packs every once in a while. As such, I'm not surprised that multiple full updates and hotfixes have rolled out with neither a fix nor a response.


Looking forward to a fix."


I was told 10 months ago that this issue was "forwarded to our QA Team", then when I provided more info five days ago, I was told to make ANOTHER bug report, on this same site, in the same category, here.

Here's the "old" post: https://support.keenswh.com/spaceengineers/pc/ticket/15892

Replies (4)

photo
1

Hello, Skye Mors!

Sorry to hear you've experienced this issue. Firstly, I'm afraid we'd only be looking at the non-modded worlds as already mentioned in the linked ticket as we ask for clean worlds due to mods interfering. It seems like you originally thought this was hardware-related as it happens on certain headsets? Is this correct? You say that things are working flawlessly but I think you found certain headsets do/don't cause the issue. Could you clarify? Could you please supply a save file without any mods where this is happening for you with reliable reproduction steps for us to try and reproduce the issue.

  • You can access your save files by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers\Saves. There should be a folder with your SteamID and your saves.
  • Please zip the file and attach it here. If you are having difficulty attaching files you can optionally use Google Drive. When sharing a google drive link please make sure it is set to be downloadable by anyone with the link.

Kind Regards

Laura, QA Department

photo
1

Out of two Surround Sound headsets, neither had spatial audio tracking for Jukeboxes.

Out of two Stereo headsets, neither had spatial audio tracking for Jukeboxes.

For a short period over a year ago the bug was determined by if you were using Surround Sound or not, and was a non-problem in Stereo. Currently the bug persists across all audio hardware.


Step 1: Put on Stereo/Surround Sound headphones

Step 2: Load/make a save with valid audio settings (either a platform/pressurized room in any environment, or Arcade mode)

Step 3: Activate Sound Block or Jukebox, making sure there is audio selected in its Control menu

Step 4: Make note of the location of the Jukebox in relation to your character

Step 5: Rotate the character (and camera), making note of the direction the Jukebox's audio is coming from

Step 6: Move the character in relation to the Jukebox, making note of the direction the Jukebox's audio is coming from

Step 7: Exit the world, or close and re-launch the game

Step 8: Put on a different pair of headphones that aren't of the same type or connection

Step 9: Load/make a save with valid audio settings (either a platform/pressurized room in any environment, or Arcade mode)

Step 10: Activate Sound Block or Jukebox, making sure there is audio selected in its Control menu

Step 11: Make note of the location of the Jukebox in relation to your character

Step 12: Rotate the character (and camera), making note of the direction the Jukebox's audio is coming from

Step 13: Move the character in relation to the Jukebox, making note of the direction the Jukebox's audio is coming from

Step 14: Exit the world, or close the game


The times you will notice the music not coming from its source are during Steps 4, 5, 6, 11, 12, 13. In all my tests in vanilla saves have had the audio not come from the relative direction of the source of the sound (Sound Block or Jukebox). I have ran this test in Vanilla saves, Modded saves, saves Re-loaded without exiting (which I have to do due to a graphical bug that happens when modded, something to do with LODs), saves before and after verifying game files, before and after reinstalling the game. I have experienced this bug in 100% of the saves I have loaded in the past 120 days.


When I mentioned it working flawlessly, I was referring to my headset and its ability to produce Surround Sound, not the game producing locational audio for Jukeboxes. Other objects such as Engines and Refineries have proper locational audio for their passive/active sounds, as well as Thrusters to a degree. Surround Sound and locational audio works with all headphones tested (just locational audio for the Stereo headphones, for obvious reasons).


Attached is a vanilla save with less than an hour of gameplay and a limited world size, with Realistic audio and both audio test zones available- a pressurized room, and one next to Medical. This can be tested with the visor up or down for either, as it's not important for it to be closed in Creative.

photo
1

Hello, Skye!

Thank you for the save and steps for this. I have been looking at this save and for me in both realistic and arcade settings, the sound from the Jukebox is emitting from the location. I have attached a video that is emitting how I imagine it should behave. When I rotate left, my right ear would be nearest the jukebox and I can hear that much louder. If I then do the opposite, I hear the sound louder in my left ear as I would expect. If I then leave the room, the sound is much quieter. This is tested on both speakers and a headset. I would be interested to know how this video sounds for you as if this does not sound how I describe it, I would say this would relate to your hardware/setup. Please let me know what you find and if I have done something obviously wrong in the video :)

Kind Regards

Laura, QA Department

photo
1

The audio from your video is correct- however, it does not match what players experience. I went to five other players, all who also confirmed that this hasn't worked for them over the past year either. We even played on the same unmodded server.

The only variable I can imagine is the game build you're using, or when that build was put together.

If you have the ability to, I would suggest redownloading the game directly from Steam on a machine that hasn't had it on it before, then following the steps.

I am amazed and more confused that you guys can't reproduce it, because of it being an issue for players for so long- it makes me want to help all the more, if it's not even an issue on whatever build you're playing on.


The only variables I don't know (that I can think of) that might affect it:

Game build version

Game build age

your audio output type


I'm going to reinstall the game once more, in hopes that it'll "fix" it, as well as ask around the Discord server who else has this issue, their audio outputs, how long they've had the game installed, etc.

photo
1

Hello, Skye!

This is played on the same version that is live on Steam currently. I have also tried the previous version with the same outcome and have come back to this with the same result. It's interesting that you do agree that this sounds correct as I wasn't expecting that! Please do try a reinstall. We also suggest the below which quite often clears peoples various issues so if you have not tried some of these, it would be a worth a try :)

  • Verify your game files in Steam

  • Right click on Space Engineers in Steam Library → Properties → Local Files → Verify Integrity of Game Files

/bfSnH0rGoN-NgctSWBJN3LfvWZvgnfye9BrPgucxV0n8TDpNc-7yZYwSifdRXyl1quu20KGUNmHzSf6VGRbhWS4a_EYn2MclxJSOz6eVarmz-fhTWVaofVOAVZN_l_leF9dgQ5GF=s0

  • Delete SpaceEngineers.cfg file

  • It means your game configuration will be deleted
  • You can access your SpaceEngineers.cfg by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers.

  • Delete ShaderCache folder

  • Back up your whole Space Engineers Roaming folder and delete it
  • Restart Steam
  • Reinstall VC Redist 2017
  • Update graphic drivers
  • Reinstall the game
  • Make sure your operating system is fully updated

Kind Regards

Laura, QA Department

photo
1

As of ten minutes ago I have performed all above steps, in the following order, testing in a new save or the save I sent (depending on if the save is available due to the steps)

1 Uninstalled game, reinstalled game

2 Deleted .cfg

3 Deleted ShaderCache folder

4 Deleted SE folder in Roaming (after backing it up)

5 Uninstalled all VC Redist, installed all currently available versions

6 Updated drivers

7 Rebooted PC fully


Still doesn't work, I figured a full reset should've fixed it... I'll try and send a vid of it not working in my next reply, 'cause it's weird that it isn't.

photo
1

Video of it not working on my end. Not much else to add, really.


https://drive.google.com/file/d/149X9_vIH7vUxvj5zvoY-bIKCEd8lusZJ/view?usp=sharing

photo
1

Hello, Skye!

Thank you for the video. Are you using any type of sound program at all? For example, a sound application that goes with your headset or something similar? Just trying to think if there is something that you're using with Space Engineers that would mean you have the issue there but not with the playback of a video.

Kind Regards

Laura, QA Department

photo
1

Technically yes, it's Logitech GHub. It only manages audio for my wireless Logitech (previously referred to as Surround Sound) headphones, meaning Stereo audio from the audio jack isn't touched by GHub (stereo from audio jack is also "broken").

I'll take a look at all programs I have, just in case, but I wouldn't think an external program would affect it due to the rest of locational audio (seemingly) working.

I'll try to get a vid of something like a hydrogen thruster producing locational sound, maybe also a jukebox.

photo
1

https://drive.google.com/file/d/1TlHLxvgnzFUafl4NChNLpBApwkMhviss/view?usp=sharing


Updated bug video. I remembered correctly- thrusters still have directional audio, but not the Jukebox. I'd have to look at the actual audio file to tell if they're directional. While looking at it, it doesn't sound like it- but while writing this part I've left it on in the background, and it sounds like that 20/80 audio split. If it's on the left, you can still hear that it's more on the left than it previously but everything is 80% on the right (unless they're working, like Thrusters).

photo
1

Third sentence I was referring to the Timer block's beeping, for clarification.

photo
1

Hello, Skye!

Thank you for this. Is it at all possible to test this without the GHub? It may be that this is the difference causing the issue as I was unable to reproduce the issue without it. If it's possible, please let me know how you get on.

Kind Regards

Laura, QA Department

photo
1

GHub is the software that handles my Logitech headphones, mouse, and keyboard. Without it, my wireless headphones are only Stereo. It also doesn't modify any audio not put through my wireless headsets.

Loaded the test world with GHub closed (and disabled), issue persists.

photo
1

Hello, Skye!

Thank you for the information. Do you have the option at all to test this on another machine? As I say, I just can't seem to reproduce the issue, and even recording the video and uploading it for you had you agree that this was sounding as expected. Do the other mentioned users use anything in common with yourself at all?

Kind Regards

Laura, QA Department

photo
1

Sadly my current PC is the only one I have right now that's powerful enough to run Space Engineers. As for shared variables with other users with the same problem, I haven't found anything. Only guess might be subscription to certain Custom Scripts, but that's a reach and I don't know enough to say whether it could even be a factor, and I can't think of anything else besides hardware that could create this issue that wouldn't be fixed with a reinstall.

photo
1

Hello, Skye!

Thank you for letting me know. Although you have re-installed, if you didn't remove everything this could be worth a shot. Please try to properly uninstall the SE once more by manually deleting all the remaining files in both - %appdata% SE folder (obviously, not your saves that you want to keep and blueprints) and from the directory where the game is installed in your Steam folder as well. It´s possible that you may have some files, configs etc broken, changed (intentionally or not) and thus these would not get properly uninstalled from your system, nor verified through Steam.

After making sure all files are uninstalled and deleted, restart your PC and try to do the fresh install. After the fresh install is done, try to run the game and see if this affects the sound at all.

Kind Regards

Laura, QA Department

photo
photo
1

Hello, Engineer!

Because there is no new comment from you, and we are unable to reproduce the issue on our own, I will close this thread now as outdated.

If you or any other player will experience this issue again, please make a new thread and provide all needed info there.

Thank you for understanding.

Kind Regards

Keen Software House: QA Department

photo
1

This is the same issue I have had with both jukeboxes and soundblocks for years now


I would be willing to send as much debug information as needed and run the game with a debugger attached to it to get to the bottom of this issue

from game logs:

MyAudio.CreateX3DAudio - Device: Speakers (THX Spatial - Synapse) - Channel #: 8 - Sample rate: 48000

(Headset: Razer Kraken kitty Edition)


Interestingly, if using the modSDK audio debug menu to play the sounds manually, they sound "normal", of course they have no positional element to them as they play in the same position as the player.


It seems that when using a surround headset with multiple audio channels, the game cant properly calculate the position that the sound should come from and just defaults to channel 0 which is the right speaker, or alternatively to a 0 position which happens to be on the right side

Leave a Comment
 
Attach a file