hydrogen not refilling

Gojan shared this bug 2 years ago
Outdated

my friend found a bug that causes him not to refill his hydrygen,

we even tried it a diffrent way which worked, but the moment we connect it back to his grid, it gets bugged.


https://cdn.discordapp.com/attachments/136097351134740480/703356140624543754/unknown.png


the one on the right doesnt work, the one on the left does work.


doesnt work for both of us, therefor it isnt a 1 person bug :P

Replies (6)

photo
1

Earlier this morning, i had issues with conveyors when i grinded them down, and welded them back up, they didnt provide ice to the survival kit, therefore it could not refill my hydroygen, but on the same note, when i played on a server, i had the same issues when trying to refill the hydroygen, and i had the same issue as the poster mentions, i even rebuild the whole system, but i think it might have been my grid that was bugged, seeing as when i removed it from the grid and placed it elsewhere, it actually worked this bug even occours when ive disconnected my ship from the grid.and after i reconnected the ship back to the grid it gave hydrogen again..

photo
1

update.

i even tried making a new world. the same happens again

-vid-

https://www.youtube.com/watch?v=psnDd5VAdt0

photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

This is happening to me as well. I've tried on several worlds, including a new Star System world, Lone Survivor world, and a Star System upgraded from a previous version.

This seems to only affect large grid systems. I've tried using a survival kit and medbay. I started with just an O2/H2 generator, but later tried with filled O2 and H2 tanks (both large and small tanks, all large grid). It seems to work for a little while when I start a new world then stops working.

photo
1

I will upvote this as I have a similar issue.

Mine is with the survival kit not supplying O2 or H2 anymore. Even though it worked without a glitch before.

I am a new player and still learning things, but i was directed here by the discord.


I have the respawn pod (bit adapted) and a very small mining ship that is 'attached' to the bigger ship through some sort of a landing platform using landing gear.

I play on a server, completely vanilla.

When I come back from mining with the little ship, I dock to my bigger ship using a connector on both the little miner and the bigger ship.

At that point the survival kit no longer supplies any O2 or H2 to my player (or other players on the server) anymore.

Undocking the small ship mean the problem presists.

The only way we've found so far to fix it :

- server restart

- using a merge block on the bugged 'bigger' ship. Merging it with a friends station, then unmerge.

Et voila the survival kit is working again.


At least till the next time I dock with the small miner.


So basically this bug is preventing me of going exploring/mining with the little ship and dumping the cargo on the big ship for refinement.

photo
1

I have created a test save that shows off this bug.


When you load in, the room should pressurize. Opening and closing the door to vent the room should let the room repressurize as normal.


Go through the door and close it behind you


Find the yellow ship nearby and use the connector to dock to the station, and immediately undock.


Return to the small room and open the door (it should vent gas as it repressurized when you left)


Enter and close the door


Check the vent. It says the room is sealed, should have no problem finding O2, but for some reason will not pressurize the room.


At this point if you save and reload, it should immediately find O2 and repressurize. I'm not sure whether there is a workaround, but reloading the save every time I dock/undock a ship from a connector isn't really something I want to do.

photo
1

I may have mistakenly thought this and another bug were the same thing. This was just the simplest way I could show what I was experiencing on a survival world, but other symptoms not shown in the provided save are things like hydrogen engines not pulling H2, cyropods not pulling O2, medical bays not pulling O2 or H2.


To me it seemed like "Block not pulling gas" was the overall bug, rather than there being one for vents and one for hydrogen.

photo
Leave a Comment
 
Attach a file