Huge Frame Drops

person shared this bug 3 months ago
Need More Information

Hi, I have recently upgraded my CPU and decided to give space engineers another try. The game runs fine for a bit but eventually starts stuttering with bad frame drops no matter how low I put my settings. My CPU is the only part on my computer spiking to 84% usage. Also, I just noticed after I pressed shift + 11 and brought up the performance monitoring menu, it said "GPU rendering load 100%" when the game started stuttering, but yet when I go to HW monitor it shows only 40% usage. Will attach my log file. Thanks.

My specs are:

Asus Rog Strix GTX 1070 OC

Intel i5 10600k

Corsair Trident Z Neo f4-3600C16D-16GTZNC 2x8gb Ram

1tb Samsung Evo SSD

Asus Prime Z-490P Motherboard

Comments (4)

photo
1

Hello, Engineer!

Sorry to hear you're experiencing this issue. Thank you for the log. Firstly, is this happening in every game mode? For example, does it happen more online or more when using mods/not using mods or does this happen in everything you attempt to play in Space Engineers? You say it runs fine for a bit then starts stuttering. Do you think this is more that you've been playing however long and it starts or are you possibly doing the same thing each time then causes it? Is this only happening since you changed your CPU? I would first suggest looking at our first steps as quite often these can help as a great first basis. Please let me know how you get on.

  • Right click on Space Engineers in Steam Library → Properties → Local Files → Verify Integrity of Game Files

/bfSnH0rGoN-NgctSWBJN3LfvWZvgnfye9BrPgucxV0n8TDpNc-7yZYwSifdRXyl1quu20KGUNmHzSf6VGRbhWS4a_EYn2MclxJSOz6eVarmz-fhTWVaofVOAVZN_l_leF9dgQ5GF

  • Delete SpaceEngineers.cfg file

  • It means your game configuration will be deleted
  • You can access your SpaceEngineers.cfg by typing %appdata% into your Windows search bar and you will be redirected to the hidden Roaming folder. After that just follow: \Roaming\SpaceEngineers.

  • Delete ShaderCache folder

  • Back up your whole Space Engineers Roaming folder and delete it
  • Restart Steam
  • Reinstall VC Redist 2017
  • Update graphic drivers
  • Reinstall the game
  • Make sure your operating system is fully updated

Kind Regards

Laura, QA Department

photo
1

Hi Laura. Thank you very much for the help. None of these things seemed to fix the issue. Also I even went as far as going into my Bios and changing up some settings there. The FPS drops stutters seem to just happen everywhere randomly when looking in a certain direction. I could be on planet or in space, and the same type of fps drops eventually occur and it seems to correct itself after I alt tab out, but that is obviously pretty annoying. I've tried going into Nvidia control panel and tweaking my settings there, as well as my windows 10 settings. I searched literally the whole of google and reddit, but still was never able to find a solution, so I came to the conclusion that it was a problem with the game not being optimized to run on newer hardware like Intel 10 series 6 core processors etc. Back when I first started playing this happened but not nearly as much, and I upgraded computers in order to avoid this happening, though it is possible I have missed some settings so I will go back and test some things. Thanks.

photo
1

Oh I should also add that it doesn't matter how low I put my in game graphics settings, as there will still be fps drops and in some cases gets even worst then on high settings. Thanks.

photo
1

Hello, person!

I appreciate this thread is quite old. Did you go back and do further testing? Has anything been found since then? :)

Please let me know.

Kind Regards

Laura, QA Department