Hinges and Pistons are exploding again.

PolandSpaceProgram shared this bug 5 months ago
Reported – Awaiting fix

KEEN should investigate that, it's simple:

No mods, any concept of mobile drilling rig, ends up exploding into little pieces

got one screenshot I captured the frame when hinges were about to stop, changing options on pistons and hinges doesnt matter, still exploding.


Couple months back it was perfectly working fine without any issues, I suppose that some idiot in your team forgot about the code when releasing new DLC.

Comments (6)

photo
1

Hello, PolandSpaceProgram!

Sorry to hear you're experiencing this issue. I appreciate you've provided a screenshot of something that already happened however, we need to reproduce the issue to report it. If you can please provide a save file with reliable steps to reproduce the issue, we can look into this for you and get it reported. It sounds like you know what this is happening on as you mention 'mobile drilling rig' so hopefully, you are able to do this :)

Kind Regards

Laura, QA Department

photo
1

HI Laura thanks for answer :) as I stated "it's simple" here's a blueprint I did use https://steamcommunity.com/sharedfiles/filedetails/?id=2160635532

and it's not only this blueprint and not only for me, every concept is affected by this bug, I found many posts under different piston/hinge/blueprint mods, people are complaining about those explosions in the comments but not here... if KEEN actually had someone to just test a game like placing a blueprint and push a damn button and see if things are still working as intended, but No why would they?

photo
2

Hello, PolandSpaceProgram!

Thank you for the blueprint. I have successfully reproduced the issue and reported it internally.

Kind Regards

Laura, QA Department

photo
1

I'm very glad and happy to read that Laura, thank you!


it's been over 3000 hours that I play Space Engineers since 2014, from time to time I comeback and I'm trying to make the same thing over and over just to see it exploded or broken :(


Still dreaming about the day when I can finally enjoy Space Engineers without frustrations.

photo
1

Lets hope it gets fixed cause my Artillery Tank and defense shards which was working perfectly fine with the 3x3 hinges before were now spazzing out and committing KLANG and then exploding

photo
1

if you rollback your game to .197 Wasteland update this problem doesn't exist , they broke something in .198 as always

photo
photo
1

I just loaded the game on an older branch version .197 Wasteland update

this concept is working as intended. I just wonder who is sabotaging those updates.

on the picture you can notice the drill completely stopped and it doesn't wobbling at all.

photo
1

My best guess is that the lack of proper automated test coverage is sabotaging their releases. A proper CI+CD pipeline is essential for quality software development. Just my best guess based on the regression bugs we have seen so far.

photo
1

Without proper automated testing this happens on each release:

photo
1

Watching that legit made me go KABOOM in laughter

photo
photo
1

Any news, having the same issue with drill rigs large or small.

Also a similar issue with copy /paste /blueprint in something that has hinge lock enabled, twists and spins, goes up in the air eventually explodes or hits ground and breaks, this is on same drill rig so maybe adding to original issue or a completely seperate one.

photo
1

Hello, Engineers!

I´m happy to announce you that this issue is already fixed and will be introduced to the game in upcoming major update.

Kind Regards

Keen Software House: QA Department