Frostbite DLC Scenario Errors

Justin Shurie shared this bug 19 months ago
Outdated

There is no real log since the game seems to be working just fine. I have played through the frostbite scenario (up until the manufacturing line for the first data container 4 times. Each time I run into a bug. When repairing the medical station for a checkpoint, I gather the supplies and repair it. But when I press the button panel, it says activation failed. If there was something else I was supposed to do first, why would the objective list not tell me? And it was optional, so how do I move on to remove it from the list.

Second, the manufacturing line. I spent 3 hours scouring the base around it, looking for a way in. Nothing. I may have missed something, but I was already pretty bummed about the med center, so I figured hey, atleast I can fix this one. So i used the admin menu, ignore safezones, and took the data container out. But the objective still wouldnt go away. I love you guys' work on SE, and this is honestly the first real issue I have taken with the game.

Comments (5)

photo
1

You can just activate the medical station directly, after repairing it. The button on the panel simply turns that block on (it's turned off by default) so just do that by hovering on the medical panel and pressing k.

Or try grinding down the control panel just below Hack and build it up again. That might also help.

photo
1

Thats what I do, but the control panel continues to glow and the item (Repair med station) stays on objective screen. It doesnt break the game, but it annoys me alot

photo
photo
1

I think there is another error, for me there are only 3 containers, where should the 4th one be?

photo
1

Have you followed the objectives in order? You should find one a long time before the last three (which are all together in two adjacent rooms).

photo
1

Thnx it appears if forgot a message somewhere (the first one). I didn't think of that because when I found the last, then the message changed to find 4 containers

photo
photo
1

Hello, Engineer!


Thank you for your feedback! Your topic has been added between considered issues.

Please keep voting for the issue as it will help us to identify the most serious bugs.


We really appreciate your patience.


Kind Regards

Keen Software House: QA Department

photo
1

I have the same issues. And for the life of me I cannot find a way in to the Cargo B area where the data container is. Every avenue is either safe zone or indestructible. The only ways in are closed and access denied. If I continue on down the elevator and to the other 3 data containers, that whole area is deactivated and just doesn't seem right.

I might restart the whole scenario to see if that helps....

photo
1

The area with three of the data containers has a damaged battery (near the entrance under the bridge). Repairing that battery will power up the base including the panel which highlights the three in that area (if you've been following the objectives in order) two are in a side room (through a large gate) one is in the same large area as the big trailer to transport them (its hidden behind some crates near the forklift).


The one container on its own on the production line is accessed from the top floor of the research base (next to the audio log left by the scientist lady. Its next to the security section. If you stand in that large area of the undreground base which has the audio log from the trailer and look up you can see the gantry to get there above you. Just go up the stairs at the left end of the big room (left when facing the audio log).

photo
photo
1

Took about 30 minutes of running around the research labs to find my way into the manufacturing line. I don't recall the route but there is one. Once in there you can open the gate and move the data container near the door with a crane. The problem I have is the nearby truck that seems designed to haul a single data container is too big to fit through the gate. At that point I just shut off the game. I don't mind challenges but at some point they cease to be fun. I'll pick up up later, slap a piston on the truck so I can drag the container out of the manufacturing floor.

photo
1

You should repair the small transport near gate, with a landing gear on it and 2 connectors + buttons pad its the one that could move on all the road from that point.

photo
1

Thanks. I completely overlooked that little forklift. Now I'm stuck again. I'm down in the tunnels after clearing the lock down. Made it across the bridge to the research archives button panel. However, it is completely disabled and I cannot proceed. I guess I missed some trigger on my way through the tunnels but I have no idea what. Quitting again out of frustration.

photo
1

Did you restored the "power" on the structures after the 2d gate as only 1 battery have still power in it but need repair.

photo
1

I've been all over the tunnels leading to the research archives and haven't found what you are referring to. The entire research archives structure is unpowered and I've run around and around looking for a way to turn it on. I'm able to grind my way into things because the safe zone (just found that) is also unpowered. Is this a side effect of overloading the reactor above to gain access to the tunnels?

EDIT: What I ended up doing was connecting the shack on the opposite end of the bridge to the bridge. The shack had two charged batteries and that powered up the research archives. It was kind of anti-climatic because I had already gone through the research archives and disabled all of its defenses.

photo
1

No in fact 1 battery is not finished (have a look in inventory) and it's the only one with power stored in it. So you need to find this battery, repair it and then the whole complex get power and you could use the command panel to move on. Also take care about vehicule part that is on top on a Landing gear, its good one for next step.

photo
1

If you got from the caverns to the reasearch archives through the little door under the bridge (rather than the big blast door vehicle access) you should find the damaged battery near by. I think its on the left in the narrow corridor after you go through the door ahead of you.

photo
1

You also have few walkthrougt on youtube but seems they mostly stopped at this point so i will give few hints, i will re write this in more readable english later i beleive someone should make an official Frostbite sceanrio help topic somewhere to avoid to spam bugs notes :

(spoiler)

You have 1 Truck with a rotor head on back , you should get the end of the truck on TOP detached from the landing gear, then move the pistons to get it on the good position (the truck should go below it) and the 2 motors should align. When the 2 motors are align (so one enter in the other) click inside truc on button Add or Attach motor head, this should lock the 2 trucks parts and then you get a big truck able to move 3 Data block (and yes you need 4 of them...)

photo