Framerate drop

Johnny Hurst IV shared this bug 3 months ago
Won't Fix

After approximately 30 minutes (sometimes more, sometimes less) my game gets capped around 16 FPS. I made a post about this around 3 months ago, but never solved the issue. My PC is capable of running Space Engineers at a stable 120 FPS on medium graphics. I did everything that was recommended such as:

Verifying my game files.

Deleted my cfg folder.

Deleted my ShaderCache folder.

Deleted my roaming folder.

Restarted Steam.

Reinstalled VCRedist 2017.

Updated my drivers.

Reinstalled the game.

And made sure my operating system is fully updated.

Recent updates have had zero effect on this problem. I have even tried reverting to older versions to see if it was a problem with a previous update but no dice. This is with a clean install of Space Engineers. No mods whatsoever. I will include everything that was included in my last post, as well as a log from earlier today.

One of the save files I was experiencing the issue on. (Though this occurs on every world I play, even brand new ones made just to test this problem):

https://drive.google.com/drive/folders/1gqN83yTP34zndYlDr55WuW1_VjtPb3ZR?usp=sharing

Comments (3)

photo
1

I'm guessing you are running Space Engineers with unlimited FPS. This will load your graphics card to the max even on low settings and could lead to graphics card overheating. When this happens most graphics cards start to thermal-throttle which means that it reduces the speed of the GPU in order to prevent damage. Of course lowering the speed of GPU will lea to slower performance.

Try to limit the framerate of the game and see if the issue still occurs.

Or perhaps use some hardware monitoring software like HwInfo (https://www.hwinfo.com/) to monitor your computer temperatures.

PS: HwInfor can also monitor your CPU and GPU speed and thus help you detect and Thermal-Throttling

photo
1

Stable framerate. Meaning it is capped. Even when I'm running at 120 FPS, my GPU usage is approximately 30%.

photo
photo
1

Hello, Johnny,

sorry to hear that the issue is still happening to you.

We were all over it with my colleagues and seems that this issue might not be on our side exactly, but e.g. faulty installed graphical drivers as written here on the thread from another game.

The best would be if you could try to do what is written there - to switch the game to run on the integrated GPU (Intel). But from the log, I fear that you have none, right?

That would at least point us whether it´s our game thing, or more of your graphical card (drivers) issue.

If you are not able to switch the GPU and try to run the game on the integrated one, can you at least try to roll back to some old nVidia driver that you know the game worked fine?

Hope this might help you at least a bit.

Please let me know.

Kind Regards

Keen Software House: QA Department

photo
1

Hello, Engineers!

Because there is no new comment from you, and we are unable to reproduce the issue on our own, I will close this thread now as outdated.

If you or any other player will experience this issue again, please make a new thread and provide all needed info there.

Thank you for understanding.

Kind Regards

Keen Software House: QA Department