Dedicated Server Manager enables Experimental Mode if you say "No"

Marco Leise shared this bug 6 months ago
Reported – Awaiting fix

What I expect to happen


It seems that when you activate any experimental settings in the DS Manager, it is supposed to ask you if you want to enable Experimental Mode and when you answer "No", it would revert the conflicting settings to their original value.

32b191d35d90c28f3310654d03ff8ec0


What actually happens

The system has holes in it that lead to the DS Manager enabling Experimental Mode even when you answer "No". At that point the user has no way of knowing what the conflicting settings are that they need to change.


Reproduction steps:


  • Open the Dedicated Server Manager
  • Select "New Game"
  • then ...


Reproduction steps for case 1:

  • Click on the "Block Limits" tab
  • Change the "Block Limits Mode" to "NONE"
  • Change back to the "Other" tab (at this point the game should have interrupted the user)
  • Toggle "Experimental Mode" on and off again
  • Click "Save & Start"
  • In the message box that pops up, choose "No"

"Experimental Mode" is now enabled regardless. What happens here is that the application always assumes the last changed setting must have caused Experimental Mode to be triggered. In this case that was "Experimental Mode", so it tries to revert that. The fix is to intercept at the point of changing of "Block Limits Mode".

Reproduction steps for case 2:

  • Click on the "Players" tab
  • Change "Max Players" to 20
  • Press tab to move to the next field
  • Click on the "Others" tab
  • In the message box that pops up, choose "No"
  • Try to change "Max Players" back to 4

You are now forced to choose "Yes".

  • Switch back to the "Others" and disable "Experimental Mode"
  • Click "Save & Start"

Same result as in repro case 1.

Reproduction steps for case 3:

  • Turn "Experimental Mode" on
  • Activate various experimental settings unknowingly:
    Adaptive Simulation Quality = off
    Max Players = 20
    Block Limits = NONE
  • Turn "Experimental Mode" off
  • Click "Save & Start"

Same result as in repro case 1.

Comments (5)

photo
1

Hello, Marco!

Firstly, thank you for such good reproduction steps. I have been testing this, this afternoon and have been able to follow them well. Silly question here but do you have experimental mode on in-game while you are doing this? I ask because I have tried the steps with and without it on and actually have two different results. If I have experimental mode on, I get exactly what you are saying on each case. If I do not have it on, it has not come on with these steps. It is looking like for me if you already have it on in-game, it will overrule what you are trying to set in the dedicated settings. Have you tried it both ways? If experimental is set to off in-game and I fire up the dedicated server and try the above cases, the game will actually stay off for me. I'll be interested to hear your take on this and just verify how this works for you.

Kind Regards

Laura, QA Department

photo
1

Hello Laura, while I did have experimental mode on in the game, I got the exact same results following these steps after turning it off. I noticed that I missed something that may lead to a different result for repro case #1 though: When you change the "Block Limit" to "NONE" it had to be done with the mouse wheel instead of the drop-down menu. Otherwise the application will actually catch that and not allow you to go back to the "Other" tab without confirmation.

photo
1

Hello, Marco!

With the scrolling trick - Case 1 = result is I cannot start the game without experimental being on. I am forced to say 'no' which in turn puts experimental mode to on in the settings but I am unable to start the game with it off. If I do not do your step of Toggle "Experimental Mode" on and off again the game will start in experimental even though this does not have a tick against it in settings.

Case 2 = Same result as above. Just to double-check here, were you able to actually start the game? I was under the impression you started the game at this point but it was in experimental. For me, I cannot start it because it keeps saying 'do you want to turn that mode on?' to which as long as I say no, I cannot start the game.

Case 3 = Again, same as the two above. I cannot move on to starting a game because it keeps asking me if I want to turn the mode on.

Sorry, I think I misunderstood your original issue. I thought you were managing to start the game but it was in experimental when you didn't want it to be. For me now, I actually can't get that far. I hope this makes sense!

Kind Regards

Laura, QA Department

photo
1

Sorry for the confusion! You figured it out in the last paragraph. Technically this is a bug report about a Yes/No message box that doesn't work (or does the same either way) after performing some steps. But the concrete situation was indeed me using the app for the first time, playing around with the settings (at some point enabling Experimental Mode) and then at the end trying to disable it before starting the game. Saying "No" did the same as "Yes" and there was no indicator for what settings keep Experimental Mode enabled. (Repro case #3)

photo
1

Hello, Marco!

No problem at all. I completely understand now what you're saying. I have successfully reproduced and reported the issue. Thank you again for steps - they are such a huge help and I've passed these on :)

Kind Regards

Laura, QA Departement