Connection performance issues with hydrogen

McModder shared this bug 12 months ago
Solved

This is a Space Engineers multiplayer issue.

In a few words: hydrogen flow causes connection lags for connected players in render distance of grid hydrogen is flowed in


Examples:

Filling 2 large hydrogen tanks on small grid from large grid with 4 h2/o2 generators causes connection issues simular to hugely increased ping

Filling 16 large hydrogen tanks on same grid causes desync (and disconnect with timeout) for most connected players and "game is paused" error for most players trying to connect to the game. Other players (with smaller ping) experienced connection issues simular to hugely increased ping


Connection issues strength seems to be dependent on:

* hydrogen flow strength (more h2/o2 generators or more hydrogen tanks - more connection lags)

* player ping (higher base ping - less hydrogen flow required for reproducing the issue) (we tested players with ~10ms ping, ~20ms ping and ~40ms ping)


When save is loaded in singleplayer no lags is present for host, but other players experiencing described issues when connecting


Example save: https://files.modder.pw/.secure-contain-protect/KeenBugTest.zip (creative, no mods, default settings for custom world, grid coords: GPS:BASE:-37507.9:-36790.46:-35070.14:#FF75C9F1:)

Comments (2)

photo
1

Hello, McModder,

thanks for letting us know your issue and for all the interesting info provided! Issue was successfully reproduced and put into our internal system.

Kind Regards

Keen Software House: QA Department

photo
1

Hello, McModder,

this issue shall be already fixed with 197.1 update. I can not reproduce it anymore in such big ping numbers difference.

Will close this thread now.

If you came across anything else or you observe the behavior persist, please make a new thread so we can process it again.

Kind Regards

Keen Software House: QA Department