Cockpit can't control the wheels

Vincent shared this bug 10 months ago
Not a Bug

c6f134df615f35940f515ac3ed81b9c2

I have tried to build a service vehicle which would have a cockpit that can raise up using piston. One of the problems I experienced is that wheels don't move when I try to control them through the cockpit, but the wheels work only when I manually override them through configuration.

I have tried setting the cockpit as main cockpit, didn't work. I also checked to see if there's power, if wheels have propulsion, everything is okay there

Comments (3)

photo
1

Hello, Engineer!


Unfortunately this is a correct behavior. Cockpit doesn't control wheels which are "sub grids", it only controls wheels directly connected to it.


This means you can't control wheels which are connected with cokpit with piston or rotor.


Kind Regards

Keen Software House: QA Department

photo
1

@Vincent so far it works as Keen Support wrote. Please create feedback to change it.

They might add some selection for cockpit for thrusters and wheels on other grids for manuvering.

Simple as elements in up/down/left/right/forward/backward groups

photo
2

@Vincent Or you can try Whip's Subgrid Wheel Control Script

https://steamcommunity.com/sharedfiles/filedetails/?id=1445055239